Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 1.9.8
    • Component/s: SCORM
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      If you import a SCORM package 2004 4th Edition (version defined in the <schemaversion> tag of the immanifest.xml), it's detected as SCORM_1.2 while it should be SCORM_1.3 (the problem is in datamodels/scormlib.php) .
      A patch is attached to correct this, but maybe something more flexible can be done.

        Gliffy Diagrams

          Attachments

            Activity

            danmarsden Dan Marsden added a comment -

            thanks for the report and patch - this is now in Moodle 1.9Stable and HEAD - feel free to submit any other SCORM 2004 bugs with patches - 2004 needs a lot of work.

            thanks,


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Mar/10