Moodle
  1. Moodle
  2. MDL-21644

Remove the protected keyword from moodle 1.9.X

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 1.9.8
    • Component/s: General
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      26576

      Description

      Moodle 1.9.X only requires php 4. Moodle 2 requires php 5. http://docs.moodle.org/en/admin/environment/php

      Support for access level keywords (public, protected, private) wasnt added until php 5. Thus the protected keyword shouldn't appear anywhere in moodle 1.9.X

      There's at least one instance. grade/report/lib.php line 333. A quick search turned up a second instance in lib/simpletestlib/exceptions.php at line 118

        Activity

        Hide
        Andrew Davis added a comment -

        Patch attached.

        Show
        Andrew Davis added a comment - Patch attached.
        Hide
        Petr Škoda added a comment -

        please commit asap, thanks

        Show
        Petr Škoda added a comment - please commit asap, thanks
        Hide
        Andrew Davis added a comment -

        committed.

        Show
        Andrew Davis added a comment - committed.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: