Moodle
  1. Moodle
  2. MDL-2176

Improve Camino sniffing for using WYSIWYG editor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.3
    • Fix Version/s: None
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_14_STABLE
    • Rank:
      10501

      Description

      In the file lib/moodlelib.php, line 3543, Moodle sniffes Camino and deactivates Midas.

      Since 11/11/2004, Camino nightly builds support the editor.

      Is there a way to make the sniffing a bit more intelligent, so that the editor could be used in Camino?

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Janne Mikkonen (janne.mikkonen at julmajanne.com) Sunday, 14 November 2004, 06:34 PM:

        I'll dig into this to night. But I'll need your help, since I do not have Mac thus cannot test it my self.

        What date this nightly build gives to Gecko (Gecko/20041111) ???

        From (moodle at martignoni.net) Sunday, 14 November 2004, 07:04 PM:

        Here is the complete user agent string:

        Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041111 Camino/0.8+

        From Janne Mikkonen (janne.mikkonen at julmajanne.com) Sunday, 14 November 2004, 07:29 PM:

        Thanks!

        I'll check into it to night. But first I'll have fathers day dinner with my family

        From (moodle at martignoni.net) Friday, 19 November 2004, 03:03 PM:

        Any news Janne? How can I help?

        From Janne Mikkonen (janne.mikkonen at julmajanne.com) Friday, 19 November 2004, 06:59 PM:

        If you also have older version of Camino it'd be userful information too that the editor doesn't load.

        After that I'll put the changes to cvs.

        From (moodle at martignoni.net) Friday, 19 November 2004, 09:59 PM:

        Here is the useragent string of a pre-release version of 0.8.2 of Camino:

        Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041102 Camino/0.8.2

        I don't know yet whether the release 0.8.2 will incorporate the midas fix. If it's not the case, we'll have a problem, since the build date (eg. Gecko/20041118) will be more recent and the editor won't work.

        I suggest to test also against version number: if the build is Gecko/20041111 or later AND version is 0.8+, activate, else no.

        What do you think?

        From Janne Mikkonen (janne.mikkonen at julmajanne.com) Tuesday, 23 November 2004, 02:39 AM:

        Changes are in cvs now.

        If it works, close this issue.

        Cheers,

        Janne

        From (moodle at martignoni.net) Tuesday, 23 November 2004, 06:33 AM:

        It works. Many thanks !

        Ciao

        Nicolas

        Show
        Martin Dougiamas added a comment - From Janne Mikkonen (janne.mikkonen at julmajanne.com) Sunday, 14 November 2004, 06:34 PM: I'll dig into this to night. But I'll need your help, since I do not have Mac thus cannot test it my self. What date this nightly build gives to Gecko (Gecko/20041111) ??? From (moodle at martignoni.net) Sunday, 14 November 2004, 07:04 PM: Here is the complete user agent string: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041111 Camino/0.8+ From Janne Mikkonen (janne.mikkonen at julmajanne.com) Sunday, 14 November 2004, 07:29 PM: Thanks! I'll check into it to night. But first I'll have fathers day dinner with my family From (moodle at martignoni.net) Friday, 19 November 2004, 03:03 PM: Any news Janne? How can I help? From Janne Mikkonen (janne.mikkonen at julmajanne.com) Friday, 19 November 2004, 06:59 PM: If you also have older version of Camino it'd be userful information too that the editor doesn't load. After that I'll put the changes to cvs. From (moodle at martignoni.net) Friday, 19 November 2004, 09:59 PM: Here is the useragent string of a pre-release version of 0.8.2 of Camino: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041102 Camino/0.8.2 I don't know yet whether the release 0.8.2 will incorporate the midas fix. If it's not the case, we'll have a problem, since the build date (eg. Gecko/20041118) will be more recent and the editor won't work. I suggest to test also against version number: if the build is Gecko/20041111 or later AND version is 0.8+, activate, else no. What do you think? From Janne Mikkonen (janne.mikkonen at julmajanne.com) Tuesday, 23 November 2004, 02:39 AM: Changes are in cvs now. If it works, close this issue. Cheers, Janne From (moodle at martignoni.net) Tuesday, 23 November 2004, 06:33 AM: It works. Many thanks ! Ciao Nicolas
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: