Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 2.0
    • Component/s: Groups
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Cohorts are "groups" of users defined above the course context. It can be used for the following purposes:

      • simplify manual enrolments - instead of adding users one by one, select cohort and enrol all users from it, one-time sync only
      • cohort enrolment plugin - continuous synchronisation of cohorts with course enrolment (optionally assign role and group)
      • allow synchronisation of cohorts with external systems - such as ldap

      Proposal and details at: http://docs.moodle.org/en/Development:Cohorts

        Gliffy Diagrams

          Issue Links

            Activity

            Dan Poltawski added a comment -

            The goals specified seem to cover exactly what I think the use case for 'global groups' are

            Ralf Hilgenstock added a comment -

            some more specs:

            users can be in more than one group
            cohorts can be used for groups in courses
            user bulkupload supports adding users to cohorts
            cohort names can be changed (i.e. class 1-> class2), what happens if a cohort related name in auth tool is been changed?
            teacher can add a cohort and single userto a course (in difference to metacourse user management)

            Martin Dougiamas added a comment -

            Ping!

            Petr Skoda added a comment -

            pong! - you can see current work in progress here http://github.com/skodak/moodle/compare/cvshead...cohorts - it does not have any use yet, just cohorts internals and basic management UI

            Petr Skoda added a comment -

            sending patch for review

            Martin Dougiamas added a comment -

            +1 from me.

            It's not doing much yet obviously but the foundation seems solid and clean. Couldn't see any problems. Go for it, thanks!

            Looking forward to seeing the role-assign part now.

            Petr Skoda added a comment -

            closing this issue for now, going to file new issue for enrol/cohort plugin, please file new issues for feature requests or regressions, thanks

            B Johnson added a comment -

            Cohorts (site wide groups) are an invaluable feature, thank you! The support for them in the UI still seems very basic though, lacking:

            • Filtering by Cohort on the Bulk User Actions and List Users screens - see MDL-22404
            • 'Add to cohort' action on the Bulk User Actions screen - see related workflow discussion at MDL-26612
            • Specifying cohort when uploading users (now scheduled for v2.0.4)

            Improving Cohort UI support is so important to us, we're planning to implement ourselves if necessary. If the team is interested in integrating our changes into core, please let me know.

            Haakon Meland Eriksen added a comment -

            Hi, I've installed the latest 2.1+ and I'm trying to understand what is currently possible with Cohorts versus Meta-course.

            My setup is geared towards 1st through 10th grade pupils in Norway.

            In version 1.9, I decided to name a course with the year the pupils leave secondary school, like 2012 for pupils who are finished by summer 2012, added users to it, and then hid it from view. I then created ten courses as meta-courses named 1st grade through 10th grade and added resources, activities, blocks and teachers to the meta-courses. I then proceeded to link 2012 to the meta-course called 9th grade, and then move the link for 2012 from 9th grade to 10th grade. The plan is to let the teachers who inherit 9th grade find a lot of resources and activities they can reuse, and move the pupils forward year by year.

            In version 2.1+, I did the same thing before I discovered Cohorts and the plans to fully or partially deprecate Meta-courses. If fully, does that mean I should use a regular course for content and rely on Cohorts for adding users? If partially, does that mean I should keep using Meta-courses the way I do, but that I should rely on Cohorts to move pupils forward? The documentation is a bit confusing at this point, and what features are available and which are not. I noticed that at present I cannot use Cohorts safely, because if a pupil is deleted, then everything this person has done is removed - including grades, which is not acceptable in Norway. It's quite common that pupils due to family rearrangements will move away and then come back after some weeks or months, and then be given their account back. Our schools expect us to keep information about pupils we have had, and often need to transfer this information to the pupil's new school. Sorry, that was a lot of info, I'm just confused about what I should do. I really like Cohorts proposed ability to reuse existing groups in an LDAP catalog, but need to sure if I should go forward with using Cohorts yet or if it is best to wait.

            Yours sincerely,
            Haakon Meland Eriksen, Drammen, Norway

            Petr Skoda added a comment -

            Hello,

            the problem here is that you can not keep adding more and more students into one course every year, moodle data storage is not designed for that. There is also only one set of dates in each course and activity. If you need full history of each course then you should create a brand new course each year and at the end of year simply hide it and maybe move it into separate archive category.

            The enrolment is a separate problem - since 2.0 you can either do full unenrol (that means erase as much user information as possible from the course) or suspend the user enrolment (this option keeps 100% of user information intact, but the student should be hidden in gradebook and other parts; it prevents all access to course unless you enable guest access). This is may seem confusing at first, it would be nice if we could improve the enrolment user interface to communicate this more clearly.

            I think you could create cohorts for each group every year and never remove anybody from these cohorts + create separate courses every year and hide them at the end.

            Petr

            Haakon Meland Eriksen added a comment -

            Thanks for the quick reply, Petr!

            Hm, I see. The gradebook with grades for activities needs to be available across courses, so that the grades you get in the 8th grade are available when you complete the 10th grade. I work in secondary school and Food and health is a final grade in the 9th grade that needs to be on the exam paper after 10th grade. Is this possible with Moodle?

            From the schools point of view, the work you did in the 8th grade only needs to be available until the school year is over, and some days if any complaints are filed and documentation of student work needs to be looked at again.

            However, from the students and teachers point of view, many want to keep all the work they did, look at things again and so on.

            The 8th grade is the 8th grade - you cover the same level material or goals and you refine, remove and add new approaches. I want to gain more time do learn from the experiences of last year and improve how the team or the next team of teachers should do it.

            At my secondary school this autumn we have the Graduates of 2012, Graduates of 2013 and Graduates of 2014.

            If I first create three course categories - "Gratuates of 2012" and so on - and secondly add 10 meta-courses to each of them named "10th grade autumn 2011 - spring 2012", "10th grade autumn 2012 - spring 2013", "10th grade autumn 2013 - spring 2014" and so on. The way I see it, I can at year's leave everything as it is and make a final backup of say "10th grade autumn 2011 - spring 2012" without most user content (glossaries or databases should maybe be kept) - keeping all resources and activities and restoring this backup into "10th grade autumn 2012 - spring 2013" before schools begins in the autumn. Students then don't have to removed from anything until they are done. Assuming it's available, it may even allow any student in need of advanced material to get it.

            If a student is allowed to enter several courses, is it possible to set a standard course or home course upon login, like the year they are supposed to be in? Like the "standard printer"-setting? Then I don't have to hide previous or later courses, as the students for the most part will be in the course they're supposed to be. Hm. If previous grades are locked, that shouldn't be a problem, should it?

            I see now that I have in a long-winded way mostly described what you said in your last sentence. Do you see any problems with this approach besides the growing size of the database?

            However, before using cohorts I need to be sure that removed/reinstated students who move away and come back can find what they've done. Cohorts at present warns that this may be deleted.

            Cheers,
            Haakon


              People

              • Votes:
                3 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: