Moodle
  1. Moodle
  2. MDL-21934

Setting Quiz value to 0 shuffles the feedback fields.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.8, 2.1.1, 2.2
    • Fix Version/s: 2.1.2
    • Component/s: Quiz
    • Labels:
      None
    • Database:
      MySQL
    • Testing Instructions:

      1. Create or find a quiz with some questions, but no student attempts yet.
      2. Add at least two lots of overall feedback, with a grade boundary between them.
      3. Remove all the questions from the quiz. Note that Maximum grade does not change.
      4. Check the settings form, and verify the overall feedback is still there.
      5. Now add the questions back into the quiz.
      6. Change the grade for each question to 0.
      7. At the moment when the last question's grade is set to 0, verify that the quiz Maximum grade is also set to 0.
      8. Verify that on the quiz settings form, there is now only one log of overall feedback visible.

      Show
      1. Create or find a quiz with some questions, but no student attempts yet. 2. Add at least two lots of overall feedback, with a grade boundary between them. 3. Remove all the questions from the quiz. Note that Maximum grade does not change. 4. Check the settings form, and verify the overall feedback is still there. 5. Now add the questions back into the quiz. 6. Change the grade for each question to 0. 7. At the moment when the last question's grade is set to 0, verify that the quiz Maximum grade is also set to 0. 8. Verify that on the quiz settings form, there is now only one log of overall feedback visible.
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      I have a quiz worth 10 points. It has a few questions in it. My test quiz has feedback as follows. 100% "top", 50% "middle", 30% "bottom"
      I go to the Edit tab and set the maximum grade to 0 and save. Now I go back to the Update this Quiz section and find that the order is now 100% "bottom", 50% "middle", 30% "top"

      If this were a real quiz, my students would be told that they failed a quiz after getting a 100% on it.

        Gliffy Diagrams

          Issue Links

            Activity

            Tim Hunt added a comment -

            If the quiz is out of 0, then the percentages are meaningless, aren't they? (In Moodle 2.0, it would stop you entering more than one lot of feedback in that case.)

            Matthew Davidson added a comment -

            That is true, but if I change it back to 10 later on it doesn't realign the feeback. And unless you are aware that setting a quiz to 0 shuffles your feedback you might not even look at it. Besides, does the fact that you "might not" be using the feedback mean that shuffling the feedback is not a bug?

            Tim Hunt added a comment -

            If there are questions in the quiz, and they are all worth zero, then the maximum grade for the quiz must also be zero, and Moodle 2.1+ ensures that.

            However, if while working on the quiz, you just remove all the questions and add them back (or add some different one) then the maximum mark and overall feedback should not be affected.

            Argh! but, what about the situation when you remove all the questions except for one description? Grrr! that case is still broken.

            Tim Hunt added a comment -

            Hmm. There is really nothing we can do in this case, because system will let a student start a quiz attempt when the quiz comprises just a description. The only way to fix this properly would be to write a very careful

            quiz_has_at_least_one_real_question($quiz)

            function, and that would be computationally expensive, because it would require at least one database query. The change I have made here is definitely a step in the right direction, so I think we should integrate this for now, and worry about obscure edge cases later.

            Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            Rajesh Taneja added a comment -

            Works Great...
            Thanks for fixing this Tim

            Eloy Lafuente (stronk7) added a comment -

            Such an effort has get its prize. Universal Award to the very-best Moodle developer in the family. Thanks!

            Closing. Ciao


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: