Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-21993

mnet upgrade does not handle dependencies at all

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: MNet
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      The problem is that "remotemoodle" repository is publishing "remoterep" but other plugins try to use it before it is installed. This is not going to work at all during the first install, sorry.

      No idea how to solve this chicken-egg problem in /lib/upgradelib.php

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: