Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Backup
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      246

      Description

      Articulate the way to send to output (currently available singleton) various messages (both from logs or by hand). Still not used, it's the responsible for showing any progress on screen for interactive backups.

      1. MDL-22144.20101118.patch
        16 kB
        Sam Hemelryk
      1. backup.progress.jpg
        40 kB

        Issue Links

          Activity

          Olli Savolainen added a comment - - edited

          Looking at http://qa.moodle.net/backup/backup.php?id=2

          Wow, good job! If we can get all wizards in Moodle closer to this, great

          Not sure what to think about the lack of a "<< Previous" button. Whether users expect to be able to use browser back button in a wizard or whether they think they can not change previous steps is unknown without testing. I understand a wizard-like prev button it requires a bit of more advanced session handling such as that implemented by PEAR quickform_controller. Does browser back button absolutely always work for making changes in previous steps? At least I got [[cannot_finish_ui_if_not_setting_ui]] error when playing with it: If the session with the wizard has expired or finished already, any of the intermediary pages should automatically forward to the first page, for starting up a new backup session (and perhaps notifying the user of why they were forwarded there).

          The persistence of the "Backup settings" on steps 2 and 3 puzzles me. The steps before confirmation should be separate so I am pretty sure the settings should not be there on page 2. On the confirmation it is okay, for review, to show what has been selected.

          If you call the third page "Confirmation and review" then in principle it should not take input, such as the file name. If it does, then the file name input should definitely not be inside the Backup settings fieldset unless it is there already in the first screen. It seems that asking for the filename last is reasonable - if you believe it is to users, too, then just take it out of the fieldset to a fieldset of its own and probably highlight the fieldset, too.

          Do not forward the last page of the wizard anywhere automatically. There is no guarantee of the user sitting at the screen and being attentive while the backup is performed (so they may get confused if they surprisingly end up outside the wizard. Instead, provide links to anywhere the user might want to go, including the place where the backup was saved (alternatively, allowing the user to download that file directly from the last page of the wizard may be useful). Also, the layout of that page is a bit confusing as it has so little content - perhaps a frame around the content? the fieldsets on the preceding pages offer useful visual separation which should be there also on the last page.

          Please use the naming and placement/order of buttons as specified at http://docs.moodle.org/en/Development:Wizard - there are strong conventions for wizards, so the closer we meet user expectations here, the more fluent their use of the wizard will be. In particular, I think the button for advancing should be "Next >>", except that on the 3rd screen it should be "Perform backup" or a similar imperative form (btw, typo on the button preform).

          Olli Savolainen added a comment -

          Also, another minor note: having numbering for the steps in the wizard status indicator may help users to understand that this is a wizard and a fixed sequence of action.

          Eloy Lafuente (stronk7) added a comment -

          Ah Olli,

          all great suggestions thanks. I'm referencing from the UI bug to your comments here. Some of them, like the one about to avoid the final automatic redirection is already there.

          I think I confused you a bit about where you should put your comments, sorry. Let me clarify things a bit:

          1) this issue is about (the output) that is the name we use to define what will be showed when the backup is being executed (last stage of the ui / wizard). That list of "creating directories, saving users.... and so on". For now this is planed to be a simple html list (similar to 1.x one, but with far less garbage) although could be extended to show progress bars / whatever in the future.

          2) the other bug (MDL-22142) is about the UI (or the wizard) so practically all the comments above "belongs" to there.

          Just to let everybody know, that's the objectives of each bug. I'm sorry I sent you to this bug, I'm sure I miss-understand you.

          Ciao

          Olli Savolainen added a comment -

          Oh, right, sorry. Yeah, I was wondering about which bug it was.

          I am trying to learn to prioritize what I recommend so I don't shout everything as critical and put too much burden on anyone.

          Great that the redirection thing is fixed, it is the most important one.

          Would say that the naming of the buttons is second since "save" implies an action before there really is one.

          Sam Hemelryk added a comment -

          Hi Eloy,

          I've attached a patch that adds a progress bar to the backup process stage.
          I doubt it is the desired way of handling it... I barely thought it out I just coded.
          But it does seem to work and it will stop browser timeouts.

          Let me know what you think.

          Cheers
          Sam

          Tim Lock added a comment -

          Hi Sam,

          I've tried this on 2.0.3 and on a large backup it will sit on 100% for several minutes, is that expected behavior?

          Eloy Lafuente (stronk7) added a comment -

          Closing this as dupe of MDL-38190 that implements the progress UI in backup, restore and import operations.


            People

            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: