Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22249

Thumbnail image link with wrong MIME type to the thumbnail itself

    Details

    • Affected Branches:
      MOODLE_19_STABLE

      Description

      (Note: if this is already fixed in 2.0, likely not worth it to fix it in 1.9 anymore. Sorry, hard to test it for me in 2.0 right now.)

      Steps to reproduce:
      1.Click the image at http://moodle.org/mod/data/view.php?d=26&rid=3764

      Browser popup will appear asking what external treatment I want to give to the file.

      There should be no link at all if the user is only going to get the same thumbnail image they are seeing already.

      Checked with wget -S, the Content type for http://moodle.org/file.php/1/moddata/data/26/123/3764/verticalblend.jpg is:
      Content-Type: application/x-forcedownload
      Instead, it should be image/jpeg.

      There is generally no reason to use application/x-forcedownload unless the user has explicitly asked to download the file. Otherwise, the standard and expected behavior is to display the image in the browser as-is. (Unless you have a viable scenario where forcing download is actually needed.)

      I do not think so but might be a bug in the instance at moodle.org, but probably in Moodle.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: