Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22317

page and resource modules... revision field incremented but not used...

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Resource
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      While implementing page and resource modules I've found that it also has the same "revision" field than imscp (MDL-22315), but it seems that it isn't it use at all.

      Am i wrong? Are versions stored ?

      My +1 to drop that both from here and from imscp.

      Ciao

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              the revision field is necessary to prevent caching problems, if it is not used it is a bug which needs to be fixed, I thought I tested it, but it is a long time ago, I am going to retest everything in these modules and update them a bit, thanks

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Ah,

              I told it was not being used... from a File Storage point of view (I did missed the "caching" point completely).

              So my suggestion to drop it was caused because of the "abuse" (IMO) we are doing in the IMSCP module of the files->itemid column for storing multiple revisions for... nothing?

              So, it revision is being used to solve caching, np at all. Consider this not a bug. About the imscp problem, MDL-22315 in the one to be fixed.

              Thanks and ciao

              skodak Petr Skoda added a comment -

              not a bug, you can restore anything into page and resource module


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10