Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Themes
    • Labels:

      Description

      Due to the splitting of base and standard theme's plus all the other work that has gone into Moodle 2.0 themes the base and standard themes as well as all of the styles.css files within plugins could do with a little TLC and a good optimisation.

      See the linked discussion for full details.

        Gliffy Diagrams

          Issue Links

            Activity

            samhemelryk Sam Hemelryk added a comment -

            Hi Patrick,

            I've added you as a watcher to this issue to make you aware of it.
            Feel free to assign this to yourself if you would like to tackle it dependently otherwise feel free to commit any optimisations you make against this issue.

            Cheers
            Sam

            lazydaisy Mary Evans added a comment -

            I'm not sure how far this got if at all. Obviously nothing much has come of it, or if it has, then it's still an ongoing process. It's a year old almost and as far as I can tell nothing much has come of it. Let's see if we can make it happen! LOL
            I'm just commenting here so that I can keep tabs on this and not let it out of site (sight).

            lazydaisy Mary Evans added a comment -

            We keep moving on with these tracker issues. Gosh how time flys when you are having fun!
            I think the time has come to get this done.
            So I will add this on to my TODO list
            Thanks
            Ciao
            Mary

            lazydaisy Mary Evans added a comment -

            Starting with Anomaly theme

            leebrent Brent Lee added a comment -

            Thank you for this!

            lazydaisy Mary Evans added a comment -

            Well I just hope this gets passed as I need to start fixing the Anomaly theme!!!

            stronk7 Eloy Lafuente (stronk7) added a comment - - edited

            Hi Mary,

            what I don't get both about his issue and MDL-25511 is that both seem to be "global" issues, with work to do across all themes... but instead:

            • this applies formatting to anomaly only.
            • MDL-25511 applies formatting to canvas only.

            So both will be closed and done (when all the css/themes have not been tidied/optimized at all).

            So, perhaps it would be a good idea to have one new, real META issue = "format properly all CSS in themes" and then add both this and MDL-25511 as subtasks, with their title changed to "format properly canvas|anomaly", each one its one?

            That way they can be safely integrated and closed, while the META continues open, adding more and more themes (subtasks) as long as you fix them.

            Awaiting for reply...

            lazydaisy Mary Evans added a comment -

            Well they say you learn by your mistakes...

            Will do!

            Cheers
            Mary

            lazydaisy Mary Evans added a comment -

            Hi Eloy,

            Can you tell me if what I have done with MDL-22351 MDL-25511 MDL-30213 is correct or have I totally misunderstood your last comment?

            Thanks
            Mary

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yeah, perfect!

            One META (MDL-30213) to rule all them, nice! And titles of children changed, superb!

            Integrating... thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Mary, due the nature of the changes (simple cleanup) I've one question:

            Do you need these changes in 2.0 and 2.1 for any good reason? By default "improvements" like this are sent only to master (upcoming 2.2), unless there is a need to backport them.

            Ciao

            PS: Don't forget to fill the testing instructions

            lazydaisy Mary Evans added a comment -

            Hi Eloy,

            I do need them in 2.0.x and 2.1.x as I am doing a major overhaul of this theme. There are some old problems which need fixing and some new additions. However the new additions (settings) can just go into 2.1.x and master.

            I just wanted the CSS tidy so I can work faster...it's a pain when it's in long lines as it was previously.

            So YES - please backport them.

            Cheers
            Mary

            stronk7 Eloy Lafuente (stronk7) added a comment -

            testing instructions, please

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            Note for tester, this is expected to be a whitespace / formatting change only, so no differences should be noticed. Some navigation using the theme should be enough. This note is because right now, the issue is missing testing instructions.

            Ciao

            abgreeve Adrian Greeve added a comment -

            Tested with firefox and google chrome. Nothing looks to be broken.

            lazydaisy Mary Evans added a comment -

            Thanks so much Adrian for testing this...I am so sorry, I got total engrossed in setting up sub-tasks in another related tracker issue and just plain forgot to add the test instructions! How time flys when you are having fun.

            Cheers
            Mary

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yes, you got this finally upstream, just in time for Moodle 2.2beta. Congrats and thanks!

            Ciao

            lazydaisy Mary Evans added a comment -

            Thanks!!!


              People

              • Votes:
                3 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  28/Nov/11