Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22352

Wiki creation breaks with PostgreSQL

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Wiki (2.x)
    • Labels:
      None
    • Environment:
      Moodle 2.0 Preview 1 (Build: 20100504) running on PostgreSQL database

      Description

      Create a new wiki (any settings, doesn't seem to matter) and on 'save & display get the attached (terminal) error message. Works fine on the MySQL instance we set up at the same time.

        Gliffy Diagrams

          Attachments

            Activity

            dougiamas Martin Dougiamas added a comment -

            Yes confirmed

            The problem is in wiki_get_subwiki_by_group() , when the parameter passed for groupid is sometimes "false".

            The origin of this is the previous call to groups_get_activity_group() returns false when groups are not used (and 0 for ALL GROUPS) so these need to be dealt with seperately before calling wiki_get_subwiki_by_group()

            dougiamas Martin Dougiamas added a comment -

            Adding Pigui

            pigui Jordi Piguillem Poch added a comment -

            Now I'm going to test the rest of the code to find similar problems.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Uhm, just saw this change in renderer.php: http://cvs.moodle.org/moodle/mod/wiki/renderer.php?r1=1.2&r2=1.3

            Isn't it missing one "not" ?

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10