Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22445

Blocks not correctly docking to side panel

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Blocks, Navigation
    • Labels:
      None
    • Environment:
      Ubuntu 10.04; Browsers: Firefox/Chromium; Latest version of Moodle 2.0 checked out of CVS earlier this evening.
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      1. Click on the 'dock' icon on a block - it correctly docks to the side panel
      2. Click on the 'undock' icon on the block in the side panel, it undocks back to its original position
      3. Click on the 'dock' icon again.

      Expected outcome:
      Panel re-docks correctly

      Actual outcome:
      Block disappears, no side-panel appears.

      Docking a different block causes the side-panel to reappear, but not the first block that was docked to the panel.

      QUICK UPDATE: Refreshing the page causes everything to reappear again.

        Gliffy Diagrams

          Attachments

          1. 1.png
            1.png
            102 kB
          2. 2.png
            2.png
            108 kB
          3. 3.png
            3.png
            103 kB
          4. 4.png
            4.png
            106 kB
          5. 5.png
            5.png
            106 kB

            Activity

            davosmith Davo Smith added a comment -

            Attachments:

            1. Shows the original screen layout
            2. Shows the 'activities' block correctly docked
            3. Shows the 'activities' block correctly undocked again

            davosmith Davo Smith added a comment -

            4. Shows the result of attempting to dock the 'activities' block again.
            5. Shows the result of successfully docking the 'navigation' block as well (note the total disappearance of the 'activities' block).

            BTW Undocking and re-docking the 'navigation' block will cause that to vanish as well (until the page is refreshed).

            dougiamas Martin Dougiamas added a comment - - edited

            Good report, Davo, thanks!

            Confirmed for me as well, on latest HEAD. Over to you Sam!

            samhemelryk Sam Hemelryk added a comment -

            Hmmm thanks for turning this up Davo, looks like we are losing a div in the movement processes causing a failure after the first dock+undock.
            Will look into this later today.
            Cheers
            Sam

            samhemelryk Sam Hemelryk added a comment -

            All fixed.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10