Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22585

Missing parent language message on weekly build 20100526

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.8
    • Fix Version/s: 1.9.9
    • Component/s: Language
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      When accessing the Language pack interface on Moodle 1.9.8+ weekly build 20100526, Moodle complains for "Missing parent language file" for each langauge installed, even if he language is parent.

      To reproduce, upgrade or install to build 20100526, then:

      • Site Administration->Language->Language pack

      Supposing the site has only English installed, the message "Missing parent language of English (en)" appears, however default English language pack does not has parent.

      In case site has more languages, th e missing language pack message is repeated.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Should be fixed now. Just one extra check was needed when looking for (parentlanguage) strings. Ciao

              andreabix Andrea Bicciolo added a comment -

              Eloy, thanks for fixing. I downloaded latest CVS (moodle_19_stable), unfortunately the issue still appears as before.

              Did you commited the fix? langimport.php still has v 1.36.2.10 2009-05-06 16:10:14 skodak Exp.

              Ciao

              danielneis Daniel Neis Araujo added a comment -

              Hello, could you please take a look at MDL-22422 that is a problem related to parentlanguage? Thanks.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Ho Andrea, I didn't forget it this time, hehe. This is my version:

              $Id: langimport.php,v 1.36.2.11 2010/05/30 10:15:55 stronk7 Exp $

              Ciao

              tsala Helen Foster added a comment -

              I've just tried updating the lang packs on my 1.9.8+ (Build: 20100601) site and obtained the message:

              Update of en_utf8 language pack skipped
              Language pack fr_utf8 was successfully updated
              Language pack nl_utf8 was successfully updated
              Language pack update completed

              I don't understand why the en_utf8 language pack update was skipped, but there were no missing parent lang messages

              andreabix Andrea Bicciolo added a comment -

              Thanks Eloy and Helen,
              that was my fault, missed a "/" in rsync. Sorry (blush). Working !

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Andrea: nice!

              Helen: I think that both any non-official lang and en_utf8 are always skipped by the langimport utility. non-officials because they simply don't exist at download.moodle.org and en_utf8 because it's bundled with moodle and it hasn't sense to update it without the rest of moodle.

              Ciao

              tsala Helen Foster added a comment -

              Thanks Eloy, I've added the information about skipped lang packs to http://docs.moodle.org/en/Language_packs

              mudrd8mz David Mudrák added a comment -

              Reviewed. closing. Sorry for this regression and thanks for the prompt fix of this, Eloy!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    8/Jun/10