Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22588

Wrong courseid in mdl_scale on course restore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.12, 1.9.8
    • Fix Version/s: 1.8.13, 1.9.9
    • Component/s: Backup, Gradebook
    • Labels:
      None
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      Today we restored a course from a 1.6.9 site to a 1.9.8 site.
      First we disabled user data for forums as mentioned in MDL-15489 in order not to get a "Could not restore modules!" error.
      After the restore the grade book was ok, but the course scales didn't show up.
      In fact the course scales were visible in a completely different course, the course with the same course id on the target site.
      This is due to a wrong courseid in mdl_scale. For some reason the original course id was not replaced with the new course id on the target site.

        Gliffy Diagrams

          Attachments

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yay, thanks for the report. Confirmed and fixed. Now scales should belong to target course on restore.

            Resolving as fixed, ciao


              People

              • Votes:
                2 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jun/10