Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22694

Upgrade of scorm from Moodle 1.9 fails if multiple references of the same scorm package exist in the same course

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: SCORM
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Upgrade of scorm from Moodle 1.9 fails if multiple references of the same scorm package exist in the same course.

      Default exception handler: Error writing to database Debug: ERROR: duplicate key value violates unique constraint "mdl_file_pat_uix"

      id | scormtype | reference | course | cmid
      -------------------------------------------------------------
      13 | local | Test1_SCORM2004.zip | 173 | 7000
      14 | local | WimbaCreate_Test/Test1_SCORM2004.zip | 173 | 7020

      The exception needs to be handled like in the resource upgrade code.

        Attachments

          Activity

            People

            Assignee:
            danmarsden Dan Marsden
            Reporter:
            tlock Tim Lock
            Tester:
            Nobody
            Participants:
            Component watchers:
            Damyon Wiese, Dan Marsden, Matteo Scaramuccia, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10