Moodle
  1. Moodle
  2. MDL-22726

Problem restoring backup with hotpot (Jmatch and Jmix)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.7
    • Fix Version/s: 1.8.13, 1.9.9, 2.1
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_21_STABLE
    • Rank:
      15086

      Description

      When you import questions in HotPot format JMatch and JMix the instructions are NOT imported.

        Activity

        Hide
        Ramon Eixarch added a comment -

        The solution is very simple....

        file: moodle/question/format/hotpot/format.php
        line: 523 (aprox)

        change $text = $xml->xml_value('hotpot-config-file,instructions');
        to $text = $xml->xml_value('hotpot-config-file,'.$xml->quiztype.',instructions');

        The XML structure of HOT potatoes XML file may have change recently. We don't know!!!

        Show
        Ramon Eixarch added a comment - The solution is very simple.... file: moodle/question/format/hotpot/format.php line: 523 (aprox) change $text = $xml->xml_value('hotpot-config-file,instructions'); to $text = $xml->xml_value('hotpot-config-file,'.$xml->quiztype.',instructions'); The XML structure of HOT potatoes XML file may have change recently. We don't know!!!
        Hide
        Tim Hunt added a comment -

        Howard, Gordon, comments on this? Is it safe to commit this change?

        Show
        Tim Hunt added a comment - Howard, Gordon, comments on this? Is it safe to commit this change?
        Hide
        Gordon Bateson added a comment - - edited

        Thanks very much for reporting this and supply the patch.

        I have committed the fix to Moodle 1.6 - 1.9, and the HEAD branch of the CVS trunk. It should be available from the Moodle downloads page within 24 hours.

        By coincidence, I found this problem myself a couple of days ago and was just about to create a tracker issue to attach the fix to, so I was very glad to find you had already done it.

        many thanks!
        Gordon

        Show
        Gordon Bateson added a comment - - edited Thanks very much for reporting this and supply the patch. I have committed the fix to Moodle 1.6 - 1.9, and the HEAD branch of the CVS trunk. It should be available from the Moodle downloads page within 24 hours. By coincidence, I found this problem myself a couple of days ago and was just about to create a tracker issue to attach the fix to, so I was very glad to find you had already done it. many thanks! Gordon

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: