Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22743

Formats of all questions are converted to moodle_auto_format after xml import

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 1.9.9
    • 1.9.10
    • Questions, Quiz
    • None
    • MOODLE_19_STABLE
    • MOODLE_19_STABLE

    Description

      It has been found when I use the Moodle XML export and import. As my questions have some javascript in it so the question type is chosen to be 'html'. However, after importing the questions, it automatically converts the question type to 'moodle auto format' and it ruins my javascript.

      It can be seen in the database table moodle_question, the questiontextformat are always set to 0 after importing. In the xml file:

      <questiontext format="html">

      Replace the "html" by "moodle_auto_format", "plain_text", "markdown", All of them give the same result questiontextformat=0 in the database table. A simple xml file is attached, just try the Moodle XML import of this file.

      A little testing on a new install of moodle 1.9.9 shows that it affect all build in question types as well as plug-in question. However, it seems that there is no problem for the import to a moodle 2.0.

      Attachments

        Activity

          People

            timhunt Tim Hunt
            hwlau hon wai lau
            Nobody Nobody
            Tim Hunt, Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Tim Hunt, Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              25/Oct/10