Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-2283

Displaying number of graded/ungraded assignments in assignment view

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.4.3
    • Fix Version/s: 2.3.2
    • Component/s: Assignment
    • Labels:
      None
    • Environment:
      All
    • Testing Instructions:
      1. Create an assignment
      2. View the front page as a user with grading permission
      3. Verify you see an extra row in the grading summary "Needs grading" (should be 0)
      4. Login as a student and make a submission
      5. Login as a grader and see "Needs grading" should be 1
      6. Grade the student
      7. Verify that needs grading should be 0 again
      Show
      Create an assignment View the front page as a user with grading permission Verify you see an extra row in the grading summary "Needs grading" (should be 0) Login as a student and make a submission Login as a grader and see "Needs grading" should be 1 Grade the student Verify that needs grading should be 0 again
    • Affected Branches:
      MOODLE_14_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      This patch will display the number of graded and ungraded assignments in the assignment view. It does not include a count of unsubmitted assignments, but is intended to give you a quick view of submitted assignments which might not be graded yet (for instance, if you start grading an assignment prior to the due date, then go back later to see if any new submissions have been made).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              cguer Carlos Guerrero added a comment -

              I think this is a very important feature that Moodle lacks as it would save teachers a long time in searching for ungraded assignments.

              bakedbean Matt Street added a comment -

              We are looking for this exact patch currently - one of our courses has a number of assignments, none of which have deadlines, so the tutor has to keep opening each assignment page checking to see if there any ungraded assignments.

              Is this patch being worked on currently? If not, we would be happy to take a look at upgrading the original patch to fit in with Moodle 1.8/1.9.

              adamann2 Ann Adamcik added a comment -

              See MDL-9622 for a 1.8+ patch.

              poltawski Dan Poltawski added a comment -

              Reassigning this very old issue to mod_assign, because I think it still applies! There is no way to find out the number of ungraded assignments I think?

              damyon Damyon Wiese added a comment -

              I added this as "Needs grading" instead and it uses the same filter as "Requires grading" in the grading table. This gives more information as it counts submissions that have been updated since they were last graded.

              rwijaya Rossiani Wijaya added a comment -

              Hi Damyon,

              Thanks for providing the patch for this issue.

              Some improvement is needed before it could be submitted for integration.

              mod/assign/locallib.php:
              1. array($this->get_course_module()->instance) would be better if it defines outside the query as $param.
              2. please fixed code alignment for the query.

              mod/assign/renderable.php
              1. It would be better to add the additional param at the end, instead of in the middle. It would help preventing code regression. (ps: if you changing this, please remember to update the code in assign/locallib.php line 2093(approx).

              The rest of the patch looks good.

              damyon Damyon Wiese added a comment -

              Thanks Rossiani,

              I have updated the patch with all your suggestions.

              I did prefer having all the count variables together but I don't feel strongly about it so I made the change.

              • Damyon
              rwijaya Rossiani Wijaya added a comment -

              Thanks Damyon for fixing the patch. It looks great.

              I will submit it for integration review.

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              samhemelryk Sam Hemelryk added a comment -

              Thanks Damyon, this has been integrated now.

              timb Tim Barker added a comment -

              Congrats, your test passed.

              nebgor Aparup Banerjee added a comment -

              yay, it works!

              This issue has been put through rigorous processes and finally swam upstream along with some 65 others this week.

              Thank you all for taking the time to get us here.

              cheers!

              migmini Miguel Humberto Miní Olivera added a comment -

              In my 2.6.4+ installation there is a difference between ungraded assignments number displayed and actual ungraded assignments. Please check if solved for 2.7 and further versions.


                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Sep/12