Moodle
  1. Moodle
  2. MDL-22951

replace SCORM player with similar player from IMSCP Module

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: SCORM
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      As part of the Moodle 2.0 work, Petr Skoda has written a new IMSCP module for Moodle 2.0 which provides a really nice clean "player" to display an IMS object and TOC - I'd like to propose that we replace the existing SCORM player with the same style interface.

      This proposal is discussed here:
      http://moodle.org/mod/forum/discuss.php?d=152895

      This change will remove the settings "width" and "height" from the SCORM settings page (which don't work reliably anyway) and rely on the theme/player to set the stage size like is managed in the new IMSCP module.

      If you click on an item in the TOC of the IMSCP module it opens a new window - this behaviour will not be replicated in the SCORM module - it will behave like the TOC in SCORM currently does - opening the item in the same page.

      As this bug will "remove" settings from SCORM I'd like as much feedback as possible before we progress with it - please post in the forum and vote on this bug if you have any feedback you would like to share.

        Gliffy Diagrams

        1. mod_scorm_fix_for_2.0.v10.patch
          42 kB
          Piers Harding
        2. mod_scorm_fix_for_2.0.v11.patch
          51 kB
          Piers Harding
        3. mod_scorm_fix_for_2.0.v12.patch
          57 kB
          Piers Harding
        4. mod_scorm_fix_for_2.0.v13.patch
          57 kB
          Piers Harding
        5. mod_scorm_fix_for_2.0.v14.patch
          58 kB
          Piers Harding
        6. mod_scorm_fix_for_2.0.v2.patch
          42 kB
          Piers Harding
        7. mod_scorm_fix_for_2.0.v3.patch
          42 kB
          Piers Harding
        8. mod_scorm_fix_for_2.0.v4.patch
          44 kB
          Piers Harding
        9. mod_scorm_fix_for_2.0.v5.patch
          40 kB
          Piers Harding
        10. mod_scorm_fix_for_2.0.v6.patch
          40 kB
          Piers Harding
        11. mod_scorm_fix_for_2.0.v7.patch
          40 kB
          Dan Marsden
        12. mod_scorm_fix_for_2.0.v8.patch
          41 kB
          Piers Harding
        13. mod_scorm_fix_for_2.0.v9.patch
          42 kB
          Piers Harding
        1. IE7-1.png
          70 kB
        2. IE7-2.png
          52 kB
        3. moodle_scorm_interface_prob.jpg
          137 kB
        4. moodle_scorm_interface.jpg
          139 kB

          Issue Links

            Activity

            Dan Marsden added a comment -

            Also - if anyone else here has time to do this work - let me know! - It's unlikely that I will have time to get this in before 2.0 but if someone else pushed the work out we could review and might squeeze it in before release.

            Piers Harding added a comment -

            2nd version of patch for IMS-CP player in mod/scorm - getting a little bit more sane now with support for 1.2/2004/AICC and popup windows

            Dan Marsden added a comment -

            adding a few more watchers to this bug - sorry for the spam guys, but I've added you as you've had some interest in the SCORM player in the past - Piers has attached a patch here for Moodle 2.0 - it would be great if some of you had the time to review this and post feedback - It would be nice to get this in before 2.0 release, but it must have some solid testing performed on it before we can go ahead and push it in,

            Piers Harding added a comment -

            3rd patch attempt. This moves the messages around on the player page to be more visible - noscript and popup etc.

            Ron Meske added a comment -

            Thank you Dan for the invite. Unfortuantely I won't be able to test Moodle 2.0 for a while.

            A concern on not having the width and height setting is that most Authoring packages do not resize the window. When I went through the code, the reason the SCORM settings did not work is because the code was treating the width as a percentage instead of a pixel setting. I do not recall if height was doing the same or if it was treating it as a pixel setting. If the settings were both treated as pixels, and the code used that as the display area for the SCO, things would work correctly. Of course, the TOC size would be in addition to the SCO window size.

            The option to turn off the TOC will still be available, correct? We typically just use single SCO activities and so there is no need for the TOC or SCO navigation buttons.

            Piers Harding added a comment -

            take 4 - reposition mode messages, and the "If you have finished viewing this resource" message

            Dan Marsden added a comment -

            Hi Ron - the width and height settings will be kept for the width/height to be used in the pop-up window (unless resized by the object itself) - but we don't intend to allow those settings to be used when opening the player in the same window - it should automatically use the right size. (hopefully!) - the other settings in the SCORM will still be available - turning off display of the toc etc.

            thanks for the feedback.

            Tim Ganly added a comment -

            Some ui controls seem to be redundant when scos are launched in a new window.

            Tim Ganly added a comment -

            But of course I should mention: Piers' patch fixes the layout bugs I saw (tested in firefox 3.3.6). Cheers!

            Tim Ganly added a comment -

            A little more testing revealed the bug in the new screen shot. When you pull the drag control to the right, the controls disapear and the text gets cut off.

            Dan Marsden added a comment -

            testing using IE 8 looks good! - same issue as Tim mentions above if you stretch the TOC all the way to the right you lose the control and can't pull it back.

            when TOC is set to "hidden" by default the navigation buttons appear and are selectable - even if there is only one sco in the object

            When TOC is shown by default and only one sco in the object, the buttons in the navigation are disabled. maybe it might be easier to hide the navigation buttons completely when only one SCO?

            Dan Marsden added a comment -

            testing on Google Chrome looks good! - same issue with losing the TOC control although the navigation buttons work as designed when the TOC is set to hidden by default and there is only one sco ( aren't selectable)

            Dan Marsden added a comment -

            using IE Tester in IE 7 in a SCORM with one SCO and TOC hidden by default.
            get the following errors when entering the player (as soon as I hit "enter")

            pop-up javascript error:
            Line: 2941
            Char: 9
            Error: Object doesn't support this property or method
            Code: 0
            URL: /mod/scorm/view.php

            asks if you want to continue running scripts hit yes, opens player then get the following pop-up error:
            Line:2650
            Char:25
            Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept focus
            Code: 0
            URL: /mod/scorm/player.php

            player loads but size of player window is very thin - if you expand the TOC it uses the full space and the object is hidden.

            Dan Marsden added a comment -

            the first Javascript pop-up error above may not be related to the new player - it's reproducable on qa.moodle.net in IE7 using IETester with the old player.

            Dan Marsden added a comment -

            should say only the first pop-up is reproduceable on the old player - the 2nd error is a new one related to the new player.

            Dan Marsden added a comment -

            Testing with IE 6 - these should be flagged as "won't fix" as IE 6 is no longer a supported browser anyway - keeping here for records.
            get the same initial JS pop-up as when testing with IE 7
            then get this one:
            Line: 152
            Char: 17
            Error: Invalid argument
            Code: 0
            URL: /mod/scorm/player.php

            TOC takes up full player window and the actual object isn't displayed unless you hide the toc or make it smaller.

            Dan Marsden added a comment -

            and just because IE tester has a 5.5 IE engine I thought I'd test with that - good thing is that you can't even login to Moodle 2.0 with 5.5 as the username and password fields on the login screen aren't viewable! - nice way to encourage people to dump their old browsers!

            Ron Meske added a comment -

            Before you discount IE 6, everyone of our corporate clients are still on Windows XP with IE 6. That amounts to 100's of thousands of users just from our clients.

            Dan Marsden added a comment -

            sorry Ron, IE 6 has already been officially deemed as "unsupported" in Moodle 2.0 see http://docs.moodle.org/en/Moodle_2.0_release_notes#System_requirements

            here's not really the place to try and convince Moodle HQ that this shouldn't happen - check out some of the forum posts about this.

            Testing IE 6 changes are a pain - if someone comes up with a fix and is willing to test all Browser versions and post the detail in the tracker a Developer might be kind enough to pick it up and fix it(after testing all the browsers themselves), but it's unlikely an IE 6 bug will be resolved it the reporter doesn't provide a patch and hasn't tested it on all the browsers we do support.

            Dan Marsden added a comment -

            ..also - some of the fixes for the player in IE 7 may even improve the display of the player in IE 6 so you might not even have a problem......

            Piers Harding added a comment -

            Patch version 5 - fixes truncated TOC when using popup window - please test - I need lots of testing done in windows with different flavours of IE - thanks.

            Cheers,
            Piers Harding.

            Piers Harding added a comment -

            Version 6 fixes a bug introduced by version 5.

            Dan Marsden added a comment -

            I've just pushed in a fix for MDL-23166 which conflicts with Piers patch above (id has been changed to cm) - sorry to those who are testing - will sort out an updated patch later tonight.

            Dan Marsden added a comment -

            updated patch to prevent conflicts caused by MDL-23166

            Tim Ganly added a comment -

            After applying v7 patch...

            This problem found on FF 3.6.6, windows XP:

            Both > and >> seem to do the same thing: move to next sco in the TOC. Same problem for < and <<. They both move to the previous item.

            Tim Ganly added a comment -

            Also after applying v7 patch, another problem:

            The window launches, but the sco's first screen doesn't load. It just sits on a blank screen with a URL like: http://localhost/Moodle_first_experiment_from_CVS/mod/scorm/loadSCO.php?a=3&scoid=10

            Tim Ganly added a comment -

            And another:

            The window launches at the correct size the first time and when the nav arrows (> and >> are clicked), but if the launched window is closed and then an item in the TOC clicked, the new window is launched full screen. It's like the player has forgotten what size was set for width and height.

            Piers Harding added a comment -

            Fixes various resizing issues with the width of the TOC.

            Piers Harding added a comment -

            Make skipprev and skipnext move to absolute first and last.

            Dan Marsden added a comment -

            Tim - the blank screen is probably due to a commit from another developer last night - I've reverted their commit and it should be working properly now if you update your code.

            Dan Marsden added a comment -

            IE8 and Firefox look good - can't lose handle from TOC

            seems to be a js bug with IE 7 - will try to trace it further

            Line 174
            Char 17
            Invalid Argument
            Code 0
            /mod/scorm/player.php

            Piers Harding added a comment -

            Look at fixing cross browser issues with setting the scorm object panel size (especially - plurk - IE6/7)

            Tim Ganly added a comment -

            Minor bug with new windows:

            I noticed that when a window is launched in a new window, the width and height settings are only obeyed for the first window launch. Subsequent launches by clicking on the TOC or << < > >> buttons are always at full screen.

            Piers Harding added a comment -

            Hi Tim - I've got a fix for the popup window resizing problem, but I'm waiting on a solution to an IE6/7 problem, and sorting out an issue with prereqs before I put up another patch.

            Thanks.,

            Tim Ganly added a comment -

            Hi Piers, in case it's relevant - have a look at MDL-23209 which might impact on this.

            Dan Marsden added a comment -

            there are 2 remaining issues with the current patch(v10) - one with the handling of Pre-requisites which Piers is sorting out and the other is related to IE 7

            It seems that on first load of the player the contents of a SCORM package don't display, but if you resize the full IE browser by maximising/changing size the contents "magically" appear! - we think this might be related to the IE peekaboo bug and have tried adding the following but that hasn't worked

             
            #scorm_content {
             position: relative;
             z-index: inherit;
            filter:alpha(opacity=100);
             zoom: 1; /* For IE */
             
            } 
            

            I've added a screenshot IE 7-1.png which shows this behaviour on first load of the page - IE7-2.png shows what happens if you resize the IE window

            Piers Harding added a comment -

            Large update to the patch incorporating an AJAX call to update the TOC each time a SCO calls LMSFinish() - this only works for SCORM 1.2, and is meant to address the problem of keeping track of prerequisites.
            Needs lots of testing.

            Cheers,
            Piers Harding.

            Piers Harding added a comment -

            My attempt at integrating the new YUI based player has run into some fairly major difficulties.
            These difficulties are centred around prerequisites, and the datamodel of the API.

            The characteristic that both of these hold in common is that on initiation, or completion of a SCO they require a complete update of state information in the browser.

            For prerequisites, this means the update of the TOC to reflect what leaves are now active/clickable.
            For the API datamodel, the values must be updated wholesale, when each SCO is entered.

            My initial attempts at resolving the prerequisites issue is to attach an AJAX call to the LMSFinish() event, which calls the server to get the data to redraw the TOC - this works under FF, but has problems under IE.

            For the refreshing of the API datamodel, I have introduced an AJAX call that gets the contents of the old mod/scorm/api.php call (the calculated javascript of the API) and evals this each time a SCO is selected to play. This can be made to work under FF, but again runs into difficulties with IE.

            At this stage, I'm running out of time, and ideas for fixing these cross browser problems.

            The only short term fix I can think of for both of these is to go back to a whole window refresh using something like window.local.href call each time a SCO is completed/ or one is selected to player - a pretty undesirable outcome in my opinion.

            Input from others would be appreciated at this time.

            Cheers,
            Piers Harding.

            Dan Marsden added a comment -

            Hi Everyone,

            we're shelving this until after 2.0 release - as much as we'd like to get it in before the 2.0 release we need to avoid any regressions that might occur from the patch - there are currently still some known issues with this patch

            • Display issues with IE 7 (hoping to get some help on this one soon)
            • Issues with display of the Datamodel changing within each sco

            We're still keen for any feedback from people who have the ability to apply this patch but we'll have to wait untill after the 2.0 release for this to go in core.

            thanks for all the help with testing!

            Piers Harding added a comment -

            Patch v12 is is a BIG improvement - with this, prerequisites, and the data model function well enough to pass the SCORM 1.2 tests.

            Piers Harding added a comment -

            OK - after yesterdays despair, I've had a bit of success in getting prerequisites, and the datamodel functioning for SCORM 1.2 - this can be found in patch version 12 (just uploaded). This still needs work on the navigation for 1.2, so that when the TOC is updated on the call to LMSFinish() it calculates next correctly, but this is largely a cosmetic problem - it now passes the SCORM 1.2 ADL test suite.

            Cheers,
            Piers Harding.

            Piers Harding added a comment -

            Improved navigation

            Piers Harding added a comment -

            So, patch 13 brings improved navigation (well - navigation that works again), and auto starting/resuming the correct SCO on player launch. We are definitely at the stage (again) where it is passing the SCORM 1.2 conformance test suite (ADL).
            Current list of outstanding things that I am aware of:

            • IE7 display issue - I don't know where this is at with all the changes that I have made
            • doing the equivalent datamodel/prerequisite changes for SCORM 2004 and AICC packages.

            Cheers,
            Piers Harding.

            Dan Marsden added a comment -

            new error with the latest patch in IE

            Line 199 Unterminated String constant
            which translates to an error printed in the JS: Undefined Var currentorg in scorm_12.js.php line 230

            fixed by adding this to top of scorm_12.js

            if (!isset($currentorg)) {
                $currentorg = '';
            }
            

            Dan Marsden added a comment -

            small regression - the option "Display course structure in player" if set to "drop down list" - no drop list is shown - I don't think we need this option anymore and we can probably remove it - but it might be a good idea to keep it just in case.

            Dan Marsden added a comment -

            Since Piers has resolved the major issues, I'd really like to commit this relatively soon - as long as we make sure it doesn't cause any major regressions in AICC and 2004 objects - Piers I presume it's a relatively quick job to add the pre-req support to AICC ? - or is it actually needed there at all?

            Pushing this fix into head will resolve the regression in MDL-23454 and fix the bugs: MDL-19954, MDL-7787, MDL-19618, MDL-23421 and will allow a much wider range of testing to occur. If we make this change we will need to re-open all SCORM QA bugs for re-testing. - adding Helen here just in case!

            I don't mind leaving the IE 7 issue there for this intial commit into head - we will resolve this before final Moodle release - having it in head might even help an IE "expert" resolve it for us.

            My last 2 comments about regressions with drop down list/ JS error will be resolved before we commit. (easy fixes)

            Piers Harding added a comment -

            Fix regressions missing pull-down toc, and $currentorg.

            Fixed TOC structure problem shown by tu955.

            Dan Marsden added a comment -

            JS issue in IE when TOC set to hidden by default:
            Line 2649
            "Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept focus"

            coming from theme/yui_combo.php
            focus: function () {
            on the line:
            aEl.focus();

            Dan Marsden added a comment -

            this patch has now been pushed into HEAD - it resolves some major regressions with SCORM objects not running at all.

            There are 3 outstanding known issues:
            MDL-23468 - IE specific issues - will be resolved shortly
            MDL-23470 MDL-23468 localised to specific SCORM packages and will be resolved very soon.

            This patch needs further testing - especially with AICC and to make sure no major regressions have been caused in SCORM 2004 objects(we don't officially "support" SCORM 2004 but we shouldn't be creating regresssions)

            If any new issues are found - please log them as new tracker issues.

            Thanks/kudos goes to Piers for the hard work he has put into this rewrite - it provides a much better UI for SCORM!


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: