Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Deferred
    • Affects Version/s: 1.9.9
    • Fix Version/s: STABLE backlog
    • Component/s: Other
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      Email from Emanuel Gruengard:

      Enclosed please find patches for the RTL / BiDi support in Moodle 1.9.x.

      These recent patches were done by Nadav, a member of our team, and tested on our development server.

      Then they were loaded into a public web GIT server from which you can download them.
      These links relate to files in the Moodle tree that are not part of the theme/standard/rtl.css, which we can update on our own through the access rights that we have to the CVS.

      The following is a link to a summary of the changes:
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=summary

      And the patches are:
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=b0b72fa19271dd5531b703f29bc186d0f80c1077
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=79e307287748d8a21b4610af6f3a9504b4b19cc4
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=81e97e386aaac8c976e6ea055368401d57bc6b19
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=80534141974bea4e24b2dda8f1cedcd25e9ab4b9
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=296aff812531246516ea6530cd4263258f53cf7e
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=d98c5bfb7680b8d114f0a3383c94c2406ea55f2f
      http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=43eb13360e292c244fafc6cb3b14e2ca61b2e033

      Please verify their correctness and add them to the standard Moodle distribution.

      There are some additional patches in the works, which we will send later on.

      Looking forward to the release of Moodle 2.0 and the task of working on its needed BiDi / Hebrew features.

        Gliffy Diagrams

        1. 20100709_MDL-22952_2.0.patch
          10 kB
          Rossiani Wijaya
        2. 20100713_MDL-22952_2.0.patch
          10 kB
          Rossiani Wijaya
        3. 20100802_MDL-22952_2.0.patch
          4 kB
          Rossiani Wijaya
        4. rtl.css
          14 kB
          Nadav Kavalerchik
        5. rtl.css
          13 kB
          Nadav Kavalerchik
        6. theme_standard_rtl.css.patch
          0.5 kB
          Nadav Kavalerchik
        1. collapsed_empty_rtl.png
          0.2 kB
        2. collapsed_rtl.png
          0.2 kB

          Issue Links

            Activity

            nadavkav Nadav Kavalerchik added a comment -

            and of course... the rtl.css inside the Standard Theme
            here is a link to its latest version:
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=blob&h=abca23f1e29d383a60b0a97aa9a848a8a2a0fba8&hb=e892f0089ca168a6e0cfe2e280dfbdf13f8f6232&f=theme/standard/rtl.css

            which changes once every two weeks or so.

            dougiamas Martin Dougiamas added a comment -

            Rosie, can you look at this by the end of the week? Needs testing and checking in.

            rwijaya Rossiani Wijaya added a comment -

            Attached patch for moodle 2.0 version.

            Adding Sam to watcher list to review the navigation section.

            Note: please add 'collapsed_rtl.png' and 'collapsed_empty_rtl.png' to pix/t folder

            Note: patch is in working progress. I'm still in the process of fixing and testing all the pages in 2.0

            Thanks.

            nadavkav Nadav Kavalerchik added a comment -

            more updates:
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=9ecfdc57a9de7427774122ca787759c70b3c18fe
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=a8603b4358507387887eff761ccdd14d19f4cccd
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=97dd1e5c0bd01898e390366a52da9776af21e137
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=10366e5b07755fd77dd2b99d69380fbd4db1639d
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=75ab05896351adf779bafc5ad48a764e7029039e
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=e76f7f015c4d3e3d36b49f9dc71922692c90f588
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=4b91c95ab43db4781aee87d0db6d56e25464f362
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=58cb2ebb85f27bd2dbeaff70fb110db52e5a5ae9
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=d5ef4bd0addd36c38d1b4562fd259511947e7e77
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=04592831ddaab7b89c58157badf4a494aa1b5207
            http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=commitdiff&h=c7ba8f35b68ce466e7449a31888a0cf9a6ea31cc

            and in general : http://www.tikshuv.org.il/gitphp/index.php?p=moodle-Hebrew-Shenkar.git&a=summary

            samhemelryk Sam Hemelryk added a comment -

            Hi Rossi,

            I've checked out the patch, there are a couple of changes that you will should make before you commit it.

            1/ Please remove the excess styles from the CSS rules you are adding to the nav/settings CSS. You don't need to set things if they have changed.
            2/ There are some display issues in IE6/7 with the header float changes. Please test in IE7 at least.

            The patches from Nadav look really good too, hope all is going well with them

            Cheers
            Sam

            rwijaya Rossiani Wijaya added a comment -

            Hi Sam,

            Thank you for reviewing the patch.

            I attached the new patch to remove excess styles in nav/settings CSS.

            Regarding the issue of IE7, I had discussion with Sam and the issue is not produce from this patch.

            nadavkav Nadav Kavalerchik added a comment -

            Is there any progress?
            since, we are ready to commit more changes.
            Thanks

            rwijaya Rossiani Wijaya added a comment -

            Hi Nadav,

            Thank you for your help with bidirectional page layout.

            Some of the changes has been committed to version 2.0. The rest of the site will soon be updated.

            Rosie

            nadavkav Nadav Kavalerchik added a comment -

            Hi Rossiani (and Martin)

            I am a Moodle developer, part of the Israeli team responsible for the Hebrew translation and BIDI / RTL
            fixes and patches for Moodle. we are currently working on version 1.9.x of Moodle and have not started working
            on Moodle version 2. as soon as you release it (officially), we will start working on it (as according to
            the road-map we gave to the Israeli ISOC which is funding the translation and maintenance of the RTL
            version of Moodle)

            So all the patches i send are for Moodle 1.9.x .

            Personally, i made some rtl patches to the Base theme of Moodle 2. (similar to yours) but it is not officially part of the
            work done by the team. and was only for personal usage. so i could start using the Moodle 2 previews
            you guys release from time to time. when the team start working on Moodle 2 i will send/post it here, officially.

            BTW,
            We also would like to start translating Moodle 2. and i am not sure if it is done solely on lang.moodle.org website
            (and based on what version of the Hebrew translation?) or is it going to be a link in the Language menu of
            the Administration block? (as it used to be). please clarify

            nadavkav Nadav Kavalerchik added a comment -

            Hi Rossiani (and Martin)

            Any progress with my git patches ?
            (Is it easy for you to use?)

            Kindly,
            Nadav

            nadavkav Nadav Kavalerchik added a comment -

            new patch/change to the theme/standard/rtl.css file
            can be found on the following git commit link:
            http://github.com/nadavkav/Moodle-RTL--Shenkar-Translation-Team-/commit/18951a8bd64fd602d0c5b4b4a6b8811240da22d4

            nadavkav Nadav Kavalerchik added a comment -

            From now on...
            ALL changes made by the Moodle Hebrew Translation Team (@Shenkar Collage, Israel)
            are placed, publicly, under github.com project:
            Moodle-RTL--Shenkar-Translation-Team (link: http://github.com/nadavkav/Moodle-RTL--Shenkar-Translation-Team-)

            Specifically, under the "rtlchanges" branch :
            http://github.com/nadavkav/Moodle-RTL--Shenkar-Translation-Team-/commits/rtlchanges

            Enjoy

            nadavkav Nadav Kavalerchik added a comment -

            Force ltr alignment of an entire help window (dialog) when in "English" viewing mode (although we are basically in rtl mode)
            http://github.com/nadavkav/Moodle-RTL--Shenkar-Translation-Team-/commit/d26b15363766b87e7e57c300484b9b968723404e

            nadavkav Nadav Kavalerchik added a comment -

            update to moodle/theme/standard/rtl.css
            (fixes regression with icons alignment in blocks)
            http://github.com/nadavkav/Moodle-RTL--Shenkar-Translation-Team-/commit/779e8cf8b683a01d507902cb8d76f0862cb1c4cb

            nadavkav Nadav Kavalerchik added a comment -

            A new Hebrew (and probably other rtl language issue) related link
            http://tracker.moodle.org/browse/MDL-25025
            (Display of Hebrew Month's name in English Calendar)

            nadavkav Nadav Kavalerchik added a comment -

            Align event's title to the right and time/date to the left

            (full and updated theme/standard/rtl.css)

            nadavkav Nadav Kavalerchik added a comment -

            Latest RTL.CSS
            (include TEXTAREA fix when HTMLAREA Editor is in HTML Mode)

            lazydaisy Mary Evans added a comment -

            @Nadav

            What happened to these?

            Cheers
            Mary

            nadavkav Nadav Kavalerchik added a comment -

            Not much, I am sad to say

            I made a special patch and distributed it myself to all major Moodle using Israeli Admins that i know.
            I am not a pushy guy. asking somthing more then once, for me, seems impudent. (me bad) and i know you, Moodle HQ, have alot on your mind with Moodle 2 so... plus, after sending two emails from my Head of Hebrew translation team - Dr' Emanuel Greengard to Martin... we decided no to push any more.

            Hope your new initiavte with the meta MDL for all Moodle 2.x.x RTL issues will solve future RTL integration patches

            lazydaisy Mary Evans added a comment -

            Can these be added to Base-RTL theme?

            What do I need to do...just tell me.

            nadavkav Nadav Kavalerchik added a comment -

            This is for Moodle 1.9.x

            I am not sure it is relevant anymore, since nobody i know will upgrade their Moodle 1.9
            All are considering migration to Moodle 2.3

            rwijaya Rossiani Wijaya added a comment -

            This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

            lazydaisy Mary Evans added a comment -

            This issue may as well be closed as it is over 3 years old, and we don't fix 1.9 any more. Moodle 2.x is currently being looked after by Nadav as and when he has time.
            It is a pity he did not have the authority back then to do this for 1.9.

            @Nadav if you are reading this let me know if we can close this?

            nadavkav Nadav Kavalerchik added a comment -

            @Mary, I am watching this. Thanks

            Let's close it.

            lazydaisy Mary Evans added a comment -

            Thanks for your work here Nadav. Sorry it never made it.
            Closing as deferred...


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: