Moodle
  1. Moodle
  2. MDL-23078

Portfolio API breaking with Online Assignment type

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Portfolio
    • Labels:
      None
    • Environment:
      Moodle: Preview 4 running on PostgreSQL
      Mahara: 1.3 beta running on PostgreSQL
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Firstly, I know its a Mahara 1.3 beta and this may be the cause, but thought I'd log it anyway.

      Mahara 1.3 and Moodle 2.0 P4 set up, SSO integration working and Portfolio API working perfectly when pushing forum posts out to Mahara, BUT...

      1. Set up an Online Text assignment;
      2. Edit a submission;
      3. Save it to Mahara;
      4. Set HTML as the export type; and...

      It breaks with the following errors (turned Debug mode on, this was as much as I could get):

      Failed to start communication with remote server: remote server error: code: , message: Failed to retrieve zipfile from remote server: Unknown error occured: 0: Coding error detected, it must be fixed by a programmer: $PAGE-, message: >, message: context accessed before it was known.ERROR 4:
      4: remote server error: code: , message: Failed to retrieve zipfile from remote server: Unknown error occured: 0: Coding error detected, it must be fixed by a programmer: $PAGE-, message: >, message: context accessed before it was known.

      More information about this error
      Stack trace:

      • line 216 of /portfolio/mahara/lib.php: portfolio_export_exception thrown
      • line 509 of /lib/portfolio/exporter.php: call to portfolio_plugin_mahara->send_package()
      • line 236 of /lib/portfolio/exporter.php: call to portfolio_exporter->process_stage_send()
      • line 242 of /lib/portfolio/exporter.php: call to portfolio_exporter->process_stage()
      • line 242 of /lib/portfolio/exporter.php: call to portfolio_exporter->process_stage()
      • line 267 of /portfolio/add.php: call to portfolio_exporter->process_stage()

        Gliffy Diagrams

          Activity

          Dongsheng Cai added a comment -

          Hi, Mark
          Thanks for your report, this issue should be portfolio api

          Penny Leach added a comment -

          This is a duplicate of http://tracker.moodle.org/browse/MDL-22001 and although the issue is present during the portfolio API, it's because of format_text changes in 2.0 that don't work outside of normal page output.

          Mark Drechsler added a comment -

          Why do I keep getting those two mixed up? Thanks Dongsheng.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: