Details

    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      1204

      Description

      Foreign fonts are not properly used in assessments and discussion forums from imported Common Cartridges. Here is the respective detailed report which a member of the Aspect project asked me to forward. The respective cartridges are attached.

      There is also a problem with Moodle when importing CC packages with Discussion or Assessment:

      • When a CC package contains discussion or assessment, the Slovenian fonts are not imported correctly. Although we use utf-8 encoding, Slovenian letters are converted during the import and therefore not displayed correctly (e.g. letter '?' is converted into sequence "Å¡", '?' into "č" and '?' into "ž" in the source files for discussion/assessment). I hope you understand the problem, otherwise I can send you some screenshots as well. It is seen if you import Test-CC-add.zip or Test-CC-add-cor.zip and check the text under the forum description. I've also uploaded this course in the ASPECT Moodle, it is under Miscellaneous named "Uporabni?ki vmesniki - TEST". Note that the topic outline and forum title have the right fonts, just the forum description is wrong.

        Activity

        Hide
        Eloy Lafuente (stronk7) added a comment -

        Confirmed. Assigning to Darko. I've restored the Test-CC-add-cor.zip file above and, while original ims-cc files (Assessment.xml for example) are 100% pure utf-8, the generated moodle.xml (I've attached it) shows SOMETIMES some chars transformed to entities.

        For example "š", is properly handled in course title, in activity titles, but transformed to "Å¡" in activitiy intro, in question names...

        Surely something is being encoded too much somewhere...

        Ciao

        Show
        Eloy Lafuente (stronk7) added a comment - Confirmed. Assigning to Darko. I've restored the Test-CC-add-cor.zip file above and, while original ims-cc files (Assessment.xml for example) are 100% pure utf-8, the generated moodle.xml (I've attached it) shows SOMETIMES some chars transformed to entities. For example "š", is properly handled in course title, in activity titles, but transformed to "Å¡" in activitiy intro, in question names... Surely something is being encoded too much somewhere... Ciao
        Hide
        Darko Miletic added a comment -

        starting

        Show
        Darko Miletic added a comment - starting
        Hide
        Darko Miletic added a comment -

        This is fixed in Moodle 2.2 and onward.

        Show
        Darko Miletic added a comment - This is fixed in Moodle 2.2 and onward.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: