Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-23187

Unable to use ratings in Moodle 2.0 Preview 4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Comments, Ratings
    • Labels:
      None
    • Environment:
      qa.moodle.net

      Description

      The UI to allow a user to rate both a forum post and a glossary entry does not appear when enabling ratings for the activity.

      Steps to reproduce:
      Using the teacher account at qa.moodle.net create a forum activity in one of the topics.
      Set forum type to: Standard forum for general use
      Set Ratings Aggregate type to: Count of ratings
      Set scale to Scale: Satisfactory

      Save and return to course.

      Have the "student" user add a post to the forum

      Have the teacher user view the discussion thread created by the student user

      Expected result: There should be an option to rate the post
      Actual result: It displays Count of rating -

        Attachments

          Activity

            People

            Assignee:
            dongsheng Dongsheng Cai
            Reporter:
            sbourget Stephen Bourget
            Tester:
            Nobody
            Participants:
            Component watchers:
            Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10