Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Themes
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      33561

      Description

      Using format white in my dev environment, I'm getting errors when trying some common pages within Moodle:

      • user view page
      • groups edit page

      Getting:

      Coding error detected, it must be fixed by a programmer: Trying to reference an unknown block region side-post
      Stack trace:
      line 779 of /lib/blocklib.php: coding_exception thrown
      line 394 of /lib/blocklib.php: call to block_manager->check_region_is_known()
      line 1149 of /lib/outputlib.php: call to block_manager->set_default_region()
      line 1121 of /lib/pagelib.php: call to theme_config->setup_blocks()
      line 963 of /lib/setuplib.php: call to moodle_page->initialise_theme_and_output()
      line ? of unknownfile: call to bootstrap_renderer->__call()
      line 133 of /group/index.php: call to bootstrap_renderer->header()

      Petr pointed me it can be a theme'ts issue and I switched to standard and the problem disappeared. Ciao

        Activity

        Hide
        Daniele Cordella added a comment -

        Ciao great Eloy.
        Thanks for the report.
        As far as I know, the problem is due to the working overload of Andrea. Maybe it is better to wait for his next comment here in this tracker issue.
        Ciao.

        Show
        Daniele Cordella added a comment - Ciao great Eloy. Thanks for the report. As far as I know, the problem is due to the working overload of Andrea. Maybe it is better to wait for his next comment here in this tracker issue. Ciao.
        Hide
        Andrea Bicciolo added a comment -

        Committed and updated version of theme. Should be fixed now, please comment if you find other issues.

        Thanks for testing!

        Show
        Andrea Bicciolo added a comment - Committed and updated version of theme. Should be fixed now, please comment if you find other issues. Thanks for testing!
        Hide
        Andrea Bicciolo added a comment -

        Shoudl be fixed.

        Show
        Andrea Bicciolo added a comment - Shoudl be fixed.
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Confirmed working, thanks Andrea. I'm back to formal_white as default theme. Ciao

        Show
        Eloy Lafuente (stronk7) added a comment - Confirmed working, thanks Andrea. I'm back to formal_white as default theme. Ciao

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: