Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-23226

'standardold' theme broken for login page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      On the login page (login/index.php), when the 'standardold' theme is selected, the following error is thrown

      Coding error detected, it must be fixed by a programmer: Trying to reference an unknown block region side-pre

      On checking the config.php for that theme we see:

      'login' => array(
      'file' => 'general.php',
      'regions' => array(),
      'options' => array('langmenu'=>true),
      ),

      I no next to nothing about Moodle 2 themes but it would seem that either is Moodle is looking for that region when it shouldn't or that it should actually be defined in the 'regions' array.

        Gliffy Diagrams

          Issue Links

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Just to say I got yesterday similar errors with another theme and it was fixed. As reference: MDL-23208

            This was the change applied to fix it: http://cvs.moodle.org/moodle/theme/formal_white/config.php?r1=1.17&r2=1.18

            Ciao

            rezeau Joseph Rézeau added a comment -

            By the way, if you are stuck and cannot log into your Moodle 2.0 site because of that error, simply remove the standardold folder from your moodle/theme folder.
            It will use the standard default theme.
            Joseph

            ptrkmkl Patrick Malley added a comment -

            I thought that standardold was there for reference only?

            howardsmiller Howard Miller added a comment -

            Hmmm.... it can't just sit there broken though.

            ptrkmkl Patrick Malley added a comment -

            Yes it can. If it's not inevitably going to end up in the 2.0 core, why spend time fixing it?

            howardsmiller Howard Miller added a comment -

            I was more tending to... please delete it then If it confuses me it will confuse others and it looks bad when you get horrible errors.

            ptrkmkl Patrick Malley added a comment -

            Ha! Let's see what Sam says. I've always ignored it.

            ptrkmkl Patrick Malley added a comment -

            Sam - is it safe to now remove standardold from the theme directory?

            samhemelryk Sam Hemelryk added a comment -

            Hi guys,

            I have fixed up the errors that were occurring within the standardold theme.
            In this case it was a misplaced block region check.

            As for whether the standardold theme should still be in core, yes I think it should.
            The idea behind it is that it is exactly the same as the standard theme except it uses the a table for layout rather than the floating divs.
            The main advantage to this is that this theme will work on legacy or sub standard browsers and avoids some of the ugly bugs you may experience with those browsers, particularly in regards to overflowing content.

            Cheers
            Sam

            lazydaisy Mary Evans added a comment - - edited

            I find it sad to discover, almost two years down the line, that standardold/layout/frontpage.php wasn't fixed at the same time as standardold/layout/general.php.
            If it had been, then I would not be linking MDL-36978 as a duplicate of MDL-23226 for practically the same reason, namely a wrongly labelled block region, which if triggered throws the same error message, albeit worded differently.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10