Moodle
  1. Moodle
  2. MDL-23284

database field of type lat/long causes the navigation block to display in the wrong spot.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      See the forum for screenshots. http://moodle.org/mod/forum/discuss.php?d=154052

      Appears to be just lat/longs but test all field types for similar issues. Seems to be due to an unclosed table.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Jonathan Harker added a comment -

            I'll test this shortly - but looks very much like a php-tidy fix I did for weird forum layouts in 1.9 a year or three ago

            Show
            Jonathan Harker added a comment - I'll test this shortly - but looks very much like a php-tidy fix I did for weird forum layouts in 1.9 a year or three ago
            Hide
            Dan Marsden added a comment -

            assigning to JH

            Show
            Dan Marsden added a comment - assigning to JH
            Hide
            Dan Marsden added a comment -

            Jonathan - did you make any progress with this?

            Show
            Dan Marsden added a comment - Jonathan - did you make any progress with this?
            Hide
            Jonathan Harker added a comment -

            Couldn't reproduce... will have another look later this week

            Show
            Jonathan Harker added a comment - Couldn't reproduce... will have another look later this week
            Hide
            Jonathan Harker added a comment -

            The problem is the param2 select box is churning out a print_error() in the middle of the <select> element, which screws up the rest of the HTML output.

            Show
            Jonathan Harker added a comment - The problem is the param2 select box is churning out a print_error() in the middle of the <select> element, which screws up the rest of the HTML output.
            Hide
            Jonathan Harker added a comment -

            Patch for CVS HEAD

            Show
            Jonathan Harker added a comment - Patch for CVS HEAD
            Hide
            Jonathan Harker added a comment -

            (better) patch for CVS HEAD.

            Show
            Jonathan Harker added a comment - (better) patch for CVS HEAD.
            Hide
            Dan Marsden added a comment -

            Hi Jonathan that get_records_select call can probably just be a standard get_records call can't it? - might look a bit simpler.

            Show
            Dan Marsden added a comment - Hi Jonathan that get_records_select call can probably just be a standard get_records call can't it? - might look a bit simpler.
            Hide
            Jonathan Harker added a comment -

            Good spotting Dan done.

            Show
            Jonathan Harker added a comment - Good spotting Dan done.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: