Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-23331

LDAP Auth Register turns out in a white page after user creation

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      2.0 Preview 3 (Build: 20100617)
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      I'm using the LDAP Authentication Plugin. Also I configure the LDAP Authentication Plugin to be the registerauth responsible, so if a user is created the script that manages that would be auth/ldap/auth.php. The problem occurs when a white page appears after trying to create a suer under these conditions. It seems a big problems I know but fortunatly it is only some global variables that are not defined. Here they are:

      The script auth/ldap/auth.php:

      In function update_user_record we need to add global $DB in the first function line.
      In function user_signup we need to add global $CFG, $DB, $PAGE,$OUTPUT;

      Hope you guys could test and push it into the trunk.

      TIA
      Federico

        Attachments

          Activity

            People

            Assignee:
            danmarsden Dan Marsden
            Reporter:
            fbotti Federico Botti
            Tester:
            Nobody
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: