Moodle
  1. Moodle
  2. MDL-23483 problems related to formal_white theme
  3. MDL-23342

Some bugs in the Lesson Activity Question Types in formal_white theme

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      Linux/Apache with all necessary components for Moodle 2.0
      Moodle 2.0 Preview 4+ (Build: 20100716)
      Fire Fox 3+ and IE-8
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      36069

      Description

      I am testing the Lesson activity in Moodle 2.0 Preview 4+ (Build: 20100716)

      I am using the Formal White Moodle Theme. I have made some changes in the color and logo, but essentially its function is the standard Formal White Theme.

      You can see the test lessons at
      http://www.musapp.com/Cm2Pm/course/view.php?id=23&topic=3
      in topic 3 titled LESSON QUESTION TYPES.

      Login as a GUEST.

      I found several problems that need to be fixed. I will outline the problems here and you can test them for yourself at the above address.

      Testing using Fire Fox version 3+ browser:

      When I edit an existing question (HTML editor is used in the main question but I can't find a way to use the HTML editor in the response boxes) , I often see these characters sprinkled in the response edit boxes:

       

      Test Lesson - 1 - Multiple Choice
      It will not accept the correct answer. It is not reading the answer field. I can't progress to the next question.

      In the other question types, When I reach the "End of Lesson" screen, it gave me the option to:
      Return to Voice ClassView grades
      There should be some space between the links.
      Should be: Return to Voice Class OR View grades

      If you quit in the middle of a lesson and return later, the system asks you:

      Do you want to start at the last page you saw?
      YesNo There should be some space or a delimiter between Yes / No.

      Testing using IE-8 browser with the latest updates.

      In IE-8, the various question types are presented, but when you click the response button, the next page is blank. You can't see the Response and you can't progress to the next question.
      You can see this happen at http://www.musapp.com/Cm2Pm/mod/lesson/view.php?id=1532. Answer the question then enter your response. The next page is blank.

      Clarence

        Activity

        Clarence Prudhoe added a comment -

        Hi,

        I discovered that the problem is in the Theme I am using.

        I am using the Formal White theme for Modern Browsers. I changed the background color, added my logo and added a footnot on the Formal White theme setup page at Administrator > Appearence > Themes > Formal White.

        I tested the lesson activity at http://qa.moodle.net and it worked fine, but that site is using the Theme "binarius".

        So I switched my site to the binarius theme and the lesson activity works perfectly on my site too.

        The bug is in the Formal White Theme.

        Thanks,
        Clarence

        Clarence Prudhoe added a comment -

        This is to clarify the comments above.

        The problem with getting a BLANK page in IE-8 is a bug in the Formal White Theme.

        The bug in the Multichoice question type is a general bug and is not related to a particualr theme.

        There are two bugs in the Lesson Activity that need attention.

        I created a test question in the QA Test Site http://qa.moodle.net/mod/lesson/view.php?id=59

        I setup the lesson to allow the student to review the question and to show the review buttons.

        1. The Multichoice question type judges all responses as INCORRECT.

        2. If you click the <Yes, I'd like to try again> button, it opens a new window with an ERROR message.

        3. If you click the <No, I just want to go on to the next question> button, it will return you to the same question.

        In the mustichoice question flow, I set a correct answer to go to "Next Page" and a wrong answer to "This Page".

        I age the same errors on my test site at http://www.musapp.com/Cm2Pm/mod/lesson/view.php?id=1531

        Thanks
        Clarence

        Martin Dougiamas added a comment -

        Reassigning this to moodle.com for the time being, since Mark Nielsen is not maintaining Lesson any more. Please comment/vote/patch any crucial bugs that affect you for 2.0 to help us prioritise fixes for the upcoming release.

        Martin Dougiamas added a comment -

        Assigning this to Daniele to look at the formal_white theme

        Helen Foster added a comment -

        Clarence, thanks for your help in testing Moodle 2.0.

        Just adding a link to the discussion about this issue: http://moodle.org/mod/forum/discuss.php?d=154349

        Daniele Cordella added a comment -

        Fixed in cvs with MDL-23252, please feel free to re-open this issue if you find something not properly working.
        Thanks for the report!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: