Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-23483 problems related to formal_white theme
  3. MDL-23342

Some bugs in the Lesson Activity Question Types in formal_white theme

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      Linux/Apache with all necessary components for Moodle 2.0
      Moodle 2.0 Preview 4+ (Build: 20100716)
      Fire Fox 3+ and IE-8
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I am testing the Lesson activity in Moodle 2.0 Preview 4+ (Build: 20100716)

      I am using the Formal White Moodle Theme. I have made some changes in the color and logo, but essentially its function is the standard Formal White Theme.

      You can see the test lessons at
      http://www.musapp.com/Cm2Pm/course/view.php?id=23&topic=3
      in topic 3 titled LESSON QUESTION TYPES.

      Login as a GUEST.

      I found several problems that need to be fixed. I will outline the problems here and you can test them for yourself at the above address.

      Testing using Fire Fox version 3+ browser:

      When I edit an existing question (HTML editor is used in the main question but I can't find a way to use the HTML editor in the response boxes) , I often see these characters sprinkled in the response edit boxes:

       

      Test Lesson - 1 - Multiple Choice
      It will not accept the correct answer. It is not reading the answer field. I can't progress to the next question.

      In the other question types, When I reach the "End of Lesson" screen, it gave me the option to:
      Return to Voice ClassView grades
      There should be some space between the links.
      Should be: Return to Voice Class OR View grades

      If you quit in the middle of a lesson and return later, the system asks you:

      Do you want to start at the last page you saw?
      YesNo There should be some space or a delimiter between Yes / No.

      Testing using IE-8 browser with the latest updates.

      In IE-8, the various question types are presented, but when you click the response button, the next page is blank. You can't see the Response and you can't progress to the next question.
      You can see this happen at http://www.musapp.com/Cm2Pm/mod/lesson/view.php?id=1532. Answer the question then enter your response. The next page is blank.

      Clarence

        Attachments

          Activity

            People

            Assignee:
            daniss Daniele Cordella
            Reporter:
            cprudhoe Clarence Prudhoe
            Tester:
            Nobody
            Participants:
            Component watchers:
            Bas Brands
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10