Moodle
  1. Moodle
  2. MDL-23419

Teacher can not publish a site to a Moodle Hub

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Hub
    • Labels:
      None
    • Environment:
      Linux (Ubuntu 1004) Apache (2.2.14) MySQL (5.1.41) PHP (5.3.2)
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      32320

      Description

      When trying to carry out MDLQA-127 you can only see the Publish option in the course administration when you are logged in as an admin user not a teacher.

        Issue Links

          Activity

          Jon Witts created issue -
          Jérôme Mouneyrac added a comment - - edited

          Sorry I forgot to mention that the teacher must have 'moodle/course:publish' capability. qa.moodle.net probably haven't set it, I add helen as watcher.

          Jérôme Mouneyrac made changes -
          Field Original Value New Value
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 2.0 [ 10122 ]
          Resolution Not a bug [ 7 ]
          Jérôme Mouneyrac added a comment -

          I found out that manager can publish byt default, I'll change the QA test, can you try again Jon? It should work.
          Thank you.

          Jon Witts added a comment -

          I was testing on my local install, not the qa site. Mary has reattempted this one and passed it. Is it expected that it will default behaviour that teachers can publish? If so do the default role assignments for a teacher need updating?

          Jon

          Jérôme Mouneyrac added a comment -

          From reading the code, the teacher should not be allowed to publish by default.

          Helen Foster made changes -
          Link This issue will help resolve MDLQA-274 [ MDLQA-274 ]
          Helen Foster added a comment -

          Jon, thanks for helping with QA testing.

          I have copied your comments in MDLQA-127 (a QA test master copy) to MDLQA-274 (a test in Moodle 2.0 QA Cycle 1). Apologies for any confusion caused by having almost identical issues! It's just a limitation of the JIRA software we are using.

          All Moodle 2.0 QA Cycle 1 tests are subtasks of MDLQA-150 whereas all subtasks of MDLQA-1 are test master copies for use in future test cycles. Hope this explains things; if not, please let me know and/or post in the testing and QA forum.

          Jon Witts added a comment -

          Helen; I think I understand that - not too sure how I picked up the master task rather than the task from cycle 1.

          Jerome; If teachers are not supposed to publish by default is this a documentation issue? I would suggest we could recommend creating a publishing teacher role that could be given to those individuals you want to allow to publish courses from your Moodle. If it is only admins or managers that have this role, it is going to create a lot of overhead for the admins / managers of a Moodle to decide which courses to be published. I would suggest that a senior teacher of a department would be better placed to make that call than an administrator.

          Jon

          Helen Foster added a comment -

          Jon, most likely you followed a link to MDLQA-127 from another QA test, perhaps MDLQA-276. Since the tests were written we've realised it's not a good idea to include links to other tests in the description!

          As for a publishing teacher role, admins can easily create one. However, I think as far as possible that the QA tests should test default settings, which is why Jerome changed the test to manager. Or are you suggesting that the default teacher role should have moodle/course:publish set to allow?

          Jon Witts added a comment -

          If the thinking is that a default teacher should not have the ability to publish courses (I think I agree with that thinking too), then I think you are right to leave it as manager for the tests. As you say a new role can be created easily or the default teacher role can be over-ridden. I think this is a point for the docs and nothing more really.

          Jon

          Helen Foster added a comment -

          Thanks Jon for your clarification. You're right about it needing to be mentioned in the docs.

          Martin Dougiamas made changes -
          Workflow jira [ 37673 ] MDL Workflow [ 65017 ]
          Martin Dougiamas made changes -
          Workflow MDL Workflow [ 65017 ] MDL Full Workflow [ 94328 ]

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: