Moodle
  1. Moodle
  2. MDL-23560

'protected' modifier found its way into Moodle 1.9.9 in question/format.php

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.9
    • Fix Version/s: 1.9.10
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      27037

      Description

      The question/format.php file has several 'protected' modifiers. Moodle 1.9.9 is supposed to be compatible with PHP4 and this construct did not appear until PHP5. This will cause syntax errors for PHP4 users.

        Issue Links

          Activity

          Hide
          Howard Miller added a comment -
          Show
          Howard Miller added a comment - Turned up here... http://moodle.org/mod/forum/discuss.php?d=154519
          Hide
          Tim Hunt added a comment -

          Oops, some idiot called tjhunt seems to have done some sloppy merging from Moodle 2.0.

          Fixed now.

          Show
          Tim Hunt added a comment - Oops, some idiot called tjhunt seems to have done some sloppy merging from Moodle 2.0. Fixed now.
          Hide
          Howard Miller added a comment -

          Ha ha ha... 'git blame' grassed you up

          Thanks Tim.

          Show
          Howard Miller added a comment - Ha ha ha... 'git blame' grassed you up Thanks Tim.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: