Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-23575

Can't insert images or media in the choice text of MCQ questions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0, 2.3, 2.4
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE

      Description

      The HTML editor is now available to edit the text of multiple choice quesitons in the Lesson module. However, when I try to insert an image or add a link to e.g. an audio file, the popup Insert (link or media or image) window is missing the necessary button or link to an uploaded file or the file picker.

      Some users do need to insert such media into the choice text of their questions (as it was possible to do in 1.9).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              yes, this is a know problem, unfortunately we need to fix issues with file editor first (target 2.0) and then refactor the code in lesson (target probably sometime in 2.0.x)

              reassigning to author of the current code

              daveyboond Steve Bond added a comment -

              Not sure I understand this. This issue suggests that the 'answer' fields of an MCQ question in Moodle 2.0 are edited using an HTML editor, but as far as I can see it is just a simple text field. Is this because it has been regressed as a result of this issue?

              The requirement for HTML editors to edit MCQ answers is listed as an unresolved issue: MDL-5309

              rezeau Joseph Rézeau added a comment -

              Steve,
              You have to switch to HTML format in the provided dropdown list, save your question and re-open to edit it, and then the HTML editor is available.

              rezeau Joseph Rézeau added a comment -

              BUMP !

              rezeau Joseph Rézeau added a comment -

              bump bump bump

              luyanfei Yanfei Lu added a comment -

              I want let student insert picture in their answer. For this bug, it becomes impossible.

              rezeau Joseph Rézeau added a comment -

              @Yanfei Lu
              What you want is not related to the bug described here.
              What version of Moodle are you using?
              What type of Lesson question do you want the student to "insert" a picture in their answer? An Essay question?
              Joseph

              luyanfei Yanfei Lu added a comment -

              Yes, I use essay question.
              I want students upload an image to show GUI program's result, so I can review all the images.

              dphazelwood Don Hazelwood added a comment -

              I have come across this in Moodle 2.2.2 using Chrome & Safari (client didn't test Firefox) on a Mac.
              I believe this is happening in all areas where editing occurs - not just MCQ.
              This is happening to an admin role on the site, however, as an admin myself, I have no problem and am able to see the 'buttons' for both images & embedded media.

              rezeau Joseph Rézeau added a comment -

              I have raised priority to Major. This really ought to be fixed for the release of 2.3.

              monidu Nicolas Dunand added a comment -

              I just noticed that I actually have reported a kind of a duplicate for this in MDL-32870, where I provide part of the solution. I'm actually able to make the HTML editor insert pictures etc. but unable to successfully backup/restore.

              stveri David Stverak added a comment -

              We have the same problem in Moodle 2.2.3+.

              jennerm Matt Jenner added a comment -

              sorry - but we have this problem too & so bumping and voting for the issue

              ks6 Kathrin Schwarz added a comment - - edited

              Sorry -> Brokenlink -> The Insert into files is not complete

              Solution:
              Change in moodle/mod/lesson/locallib.php
              line 785
              $this->_form->addElement('editor', 'answer_editor['.$count.']', $label, array('rows'=>'4', 'columns'=>'80'), $this->editoroptions);

              line 803
              $this->_form->addElement('editor', 'response_editor['.$count.']', $label, array('rows'=>'4', 'columns'=>'80'), $this->editoroptions);

              rezeau Joseph Rézeau added a comment -

              Is there any hope to see this annoying bug fixed in forthcoming moodle 2.4?

              stronk7 Eloy Lafuente (stronk7) added a comment -

              U P S T R E A M I Z E D !

              Many thanks, this is now available in all the repos (git & cvs).

              Closing, ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Doh,

              somehow this issue was closed incorrectly when processing all the integrated issues this week. (sort of most voted and current in integration filters mix). Apologies for the confusion, reseting to previous status!

              Ciao, Eloy

              mazdarx2001 Steven Swanson added a comment -

              I also noticed this problem still in moodle 2.6. Maybe 2.7 will have a fix?

              jmvedrine Jean-Michel Vedrine added a comment -

              Assigning this issue to me so that I can mark it as a duplicate of MDL-32870 (currently waiting testing) and close it.

              jmvedrine Jean-Michel Vedrine added a comment -

              Linking to MDL-32870 as a duplicate even if this issue is older and has more votes because I have a good hope that MDL-32870 makes it's way into Moodle shortly (fingers crossed !).

              jmvedrine Jean-Michel Vedrine added a comment -

              Closing as duplicate


                People

                • Votes:
                  33 Vote for this issue
                  Watchers:
                  12 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: