Moodle
  1. Moodle
  2. MDL-23657

view profile "context" error notice

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Other
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      6283

      Description

      Moodle 2.0 Preview 4+ (Build: 20100804)
      debugging ALL
      logged in as admin or teacher
      go to course / block People / Participants /
      in All Participants list, click on any particpant's name
      error message displayed:

      Error: could not insert new context level "50", instance "3". incorrect course id (3)

      • line 1815 of \lib\accesslib.php: call to debugging()
      • line 2141 of \lib\accesslib.php: call to create_context()
      • line 1254 of \calendar\lib.php: call to get_context_instance()
      • line 61 of \blocks\calendar_month\block_calendar_month.php: call to calendar_set_filters()
      • line 386 of \blocks\moodleblock.class.php: call to block_calendar_month->get_content()
      • line 339 of \blocks\moodleblock.class.php: call to block_base->formatted_contents()
      • line 851 of \lib\blocklib.php: call to block_base->get_content_for_output()
      • line 903 of \lib\blocklib.php: call to block_manager->create_block_contents()
      • line 339 of \lib\blocklib.php: call to block_manager->ensure_content_created()
      • line 7 of \theme\base\layout\general.php: call to block_manager->region_has_content()
      • line 618 of \lib\outputrenderers.php: call to include()
      • line 576 of \lib\outputrenderers.php: call to core_renderer->render_page_layout()
      • line ? of unknownfile: call to core_renderer->header()
      • line 967 of \lib\setuplib.php: call to call_user_func_array()
      • line ? of unknownfile: call to bootstrap_renderer->__call()
      • line 167 of \user\view.php: call to bootstrap_renderer->header()

      Incorrect context specified

      • line 479 of \lib\accesslib.php: call to debugging()
      • line 1259 of \calendar\lib.php: call to has_capability()
      • line 61 of \blocks\calendar_month\block_calendar_month.php: call to calendar_set_filters()
      • line 386 of \blocks\moodleblock.class.php: call to block_calendar_month->get_content()
      • line 339 of \blocks\moodleblock.class.php: call to block_base->formatted_contents()
      • line 851 of \lib\blocklib.php: call to block_base->get_content_for_output()
      • line 903 of \lib\blocklib.php: call to block_manager->create_block_contents()
      • line 339 of \lib\blocklib.php: call to block_manager->ensure_content_created()
      • line 7 of \theme\base\layout\general.php: call to block_manager->region_has_content()
      • line 618 of \lib\outputrenderers.php: call to include()
      • line 576 of \lib\outputrenderers.php: call to core_renderer->render_page_layout()
      • line ? of unknownfile: call to core_renderer->header()
      • line 967 of \lib\setuplib.php: call to call_user_func_array()
      • line ? of unknownfile: call to bootstrap_renderer->__call()
      • line 167 of \user\view.php: call to bootstrap_renderer->header()

        Issue Links

          Activity

          Dan Poltawski added a comment -

          i've seen this issue too, looks to be some truely dumb code causing it

          Dan Poltawski added a comment -

          The problem was caused by a hacky fix to the problem that the calendar links are broken for non-course pages. That continues to be the case anyway so i've created MDL-25853 for it.

          Dan Poltawski added a comment -

          I've submitted PULL-67 which fixes this issue of using invalid courseids


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: