Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.8
    • Fix Version/s: None
    • Component/s: RSS
    • Labels:
      None
    • Environment:
      Ubuntu 8.04LTS
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      For activities at the site level (course id=1), all RSS feeds are currently broken. When enabling the feeds, e.g., in a forum, the RSS icons are shown, but the feeds themselves only return an "RSS error".

      The reason is located in rss/file.php, around line 93:

       
        //Do not allow acesss to hidden courses or activities because we can not trust user id - this will be improved in 2.0
        if (!$isblog and (!$course->visible || !$cm->visible)) {
            rss_not_found();
        }

      This test does not work as expected for the site-level course, apparently because the "hidden" attribute is unavailable there.

      Improved version of the code:

       
          if (!$isblog and ( (($course->id != SITEID)&&!$course->visible) || !$cm->visible)) {

        Gliffy Diagrams

          Activity

          poltawski Dan Poltawski added a comment -

          Hi Henning,

          I believe that the visible field should be available for the site level course (and also set to visible).

          poltawski Dan Poltawski added a comment -

          I can't reproduce this. Please can you reopen if there is a way to reproduce the bug?


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: