Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-22558 Database activity 2.0 inconsistencies
  3. MDL-23787

Fields of type textarea default to HTML editor. But it lacks lacks file area support, so it's impossible to add any image or similar.

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.1.4, 2.2.1, 2.3
    • Fix Version/s: 2.1.5, 2.2.2
    • Labels:
      None
    • Testing Instructions:

      Note to testers: This must be tested specially for 21 and 22 stables, due to the imminent (next week) point releases.

      1. Create Database activity with at least two textarea field
      2. Add entry, make sure you can embed images in textareas
      3. Edit entry, make sure you can edit and save entry with embedded images

      Show
      Note to testers: This must be tested specially for 21 and 22 stables, due to the imminent (next week) point releases. 1. Create Database activity with at least two textarea field 2. Add entry, make sure you can embed images in textareas 3. Edit entry, make sure you can edit and save entry with embedded images
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
      wip-MDL-23787-master

      Description

      " Fields of type textarea default to HTML editor. But it lacks lacks file area support, so it's impossible to add any image or similar. IMO we should support some sort of "data_content" file area (with itemid being data_content->id) for this field type (and others using the html editor). "

        Gliffy Diagrams

          Activity

          nebgor Aparup Banerjee created issue -
          dougiamas Martin Dougiamas made changes -
          Field Original Value New Value
          Workflow jira [ 38113 ] MDL Workflow [ 46612 ]
          dougiamas Martin Dougiamas made changes -
          Workflow MDL Workflow [ 46612 ] MDL Full Workflow [ 74864 ]
          dougiamas Martin Dougiamas made changes -
          Fix Version/s 2.1.1 [ 10750 ]
          Fix Version/s 2.1 [ 10370 ]
          marina Marina Glancy made changes -
          Assignee moodle.com [ moodle.com ] Marina Glancy [ marina ]
          dougiamas Martin Dougiamas made changes -
          Fix Version/s 2.1.2 [ 10851 ]
          Fix Version/s 2.1.1 [ 10750 ]
          marina Marina Glancy added a comment -

          Apu, can you please look at the code

          marina Marina Glancy made changes -
          Status Open [ 1 ] Waiting for peer review [ 10012 ]
          Pull Master Diff URL https://github.com/marinaglancy/moodle/compare/master...wip-MDL-23787-master
          Pull Master Branch wip-MDL-23787-master
          Pull from Repository git@github.com:marinaglancy/moodle.git
          Peer reviewer nebgor
          nebgor Aparup Banerjee made changes -
          Original Estimate 0 minutes [ 0 ]
          Remaining Estimate 0 minutes [ 0 ]
          Status Waiting for peer review [ 10012 ] Peer review in progress [ 10013 ]
          nebgor Aparup Banerjee added a comment -

          Hi Marina,
          just done a code review :

          • consider wrapping lines if they are too long (or go too far right) - again that's for readability.

          looks good to me otherwise

          cheers,
          Aparup

          nebgor Aparup Banerjee made changes -
          Status Peer review in progress [ 10013 ] Development in progress [ 3 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Fix Version/s 2.1.3 [ 11251 ]
          Fix Version/s 2.1.2 [ 10851 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Fix Version/s 2.1.4 [ 11452 ]
          Fix Version/s 2.1.3 [ 11251 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Fix Version/s 2.1.5 [ 11553 ]
          Fix Version/s 2.1.4 [ 11452 ]
          marina Marina Glancy made changes -
          Status Development in progress [ 3 ] Waiting for integration review [ 10010 ]
          Pull from Repository git@github.com:marinaglancy/moodle.git git://github.com/marinaglancy/moodle.git
          Testing Instructions 1. Create Database activity with at least one textarea field
          2. Add entry, make sure you can embed images in textarea
          3. Edit entry, make sure you can edit and save entry with embedded images
          marina Marina Glancy added a comment -

          Apu, I finally finished it. Sorry it took so long. If you think this should be backported feel free to cherry-pick to previous versions

          stronk7 Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          nebgor Aparup Banerjee made changes -
          Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
          Integrator nebgor
          Currently in integration Yes [ 10041 ]
          nebgor Aparup Banerjee added a comment -

          err oops i was peer-reviewer - assigning to another integrator.

          nebgor Aparup Banerjee made changes -
          Status Integration review in progress [ 10004 ] Waiting for integration review [ 10010 ]
          nebgor Aparup Banerjee made changes -
          Integrator nebgor stronk7
          stronk7 Eloy Lafuente (stronk7) made changes -
          Currently in integration Yes [ 10041 ]
          stronk7 Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          samhemelryk Sam Hemelryk made changes -
          Currently in integration Yes [ 10041 ]
          stronk7 Eloy Lafuente (stronk7) added a comment - - edited

          Attaching unrelated, but discovered while looking to this, error about the "Add Entry" template becoming somehow broken by the configlib.stuff, completely displacing labels and contents.

          Crazy, crazy! Reproduced from 2.0 to 2.3.

          Edited: non-initialised $patterns and $replacements arrays @ mod/data/edit.php (global scope) are the cause for this, with those vars being used by configlib stuff. I'll add one extra commit here if finally this lands.

          stronk7 Eloy Lafuente (stronk7) made changes -
          Attachment crazyerrorever.png [ 27200 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
          stronk7 Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks! (21, 22 & master).

          Note: I've added one extra commit to fix the global scope vars commented above.

          stronk7 Eloy Lafuente (stronk7) made changes -
          Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
          Affects Version/s 2.2.1 [ 11456 ]
          Affects Version/s 2.1.4 [ 11452 ]
          Affects Version/s 2.3 [ 10657 ]
          Fix Version/s 2.2.2 [ 11552 ]
          stronk7 Eloy Lafuente (stronk7) made changes -
          Testing Instructions 1. Create Database activity with at least one textarea field
          2. Add entry, make sure you can embed images in textarea
          3. Edit entry, make sure you can edit and save entry with embedded images
          Note to testers: This must be tested specially for 21 and 22 stables, due to the imminent (next week) point releases.

          1. Create Database activity with at least two textarea field
          2. Add entry, make sure you can embed images in textareas
          3. Edit entry, make sure you can edit and save entry with embedded images
          salvetore Michael de Raadt made changes -
          Tester andyjdavis
          andyjdavis Andrew Davis made changes -
          Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
          andyjdavis Andrew Davis added a comment -

          Tested on master, 2.2 and 2.1. Works as described. Passing.

          andyjdavis Andrew Davis made changes -
          Status Testing in progress [ 10011 ] Tested [ 10006 ]
          stronk7 Eloy Lafuente (stronk7) added a comment -

          Your changes are now upstream and will be included in the next minor released scheduled for March 13th (next Monday!).

          icao_reverse('arreis olik rebemevon afla letoh ognat');

          Closing, ciao

          stronk7 Eloy Lafuente (stronk7) made changes -
          Status Tested [ 10006 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Currently in integration Yes [ 10041 ]
          Integration date 09/Mar/12

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/Mar/12