Moodle
  1. Moodle
  2. MDL-23838

In Navigation Block... surely the category names should actually link to the category page

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Navigation
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      1128

      Description

      The navigation block has drop downs for the Course Categories which display the containing courses. The courses are active links but the Course Category names are not. I wanted to get to the Category to assign some roles in that context and this would have made getting there a lot easier.

      See attached screen dump.

        Activity

        Sam Hemelryk added a comment -

        Hi Howard,

        Thanks for creating this issue, linking to the category is very easy however it was intentionally not done as it made it hard to differentiate between course and categories and the navigation is designed to allow the user to navigate through a category without having to visit it.

        That being said it is very easy to do and the navigation has changed several times since that decision was made, thus I have attached a patch to link the category names and have added Martin as a watcher.
        I should add when Done there really is no way to distinguish between a category and a course so perhaps if you want it done Martin we should fine a unique way to style a category as well.

        Cheers
        Sam

        Howard Miller added a comment -

        Hi Sam,

        Having run with a patch in 1.9 that showed the categories for years I've never had an issue. Thinking about it, I would say that the category is differentiated by its context (small 'c'). It is going to have a name like "Department A" or "Maths courses" and that should be enough. Also, users will get used to the layout of their particular Moodle. In the friendliest possible way it strikes me as a rather high-handed decision anyway. I can't think of any other web site/application with a breadcrumb trail that says "we thought you might get confused so we won't let you click the link".

        Howard Miller added a comment -

        Sam, meant to add (more ranting). Just an aside.. I seem to have been fighting a battle for years to recognise the importance of Categories. On small sites they are neither here nor there but on huge sites they become a vital organisational tool. The ability to organise your site into departments and subdepartments using categories is important (along with assigning user rights at these levels). The effect of this is that, in such an organisation, the user can't click back to their departments "home page".

        Martin Dougiamas added a comment -

        I guess the problem is more one of "if the words are a link then you have to hit the tiny arrow to drill down", which is quite tiring if you are drilling down through those menus all the time.

        Most users will already be enrolled in courses and won't need to navigate categories much so it's probably not a big deal. It really does depend on the site and the users though ... perhaps we need another site option here.

        Sam Hemelryk added a comment -

        I could probably make it an option of the block and then make the decision to render it within the blocks renderer if you like. That way it will always be a link on the navbar and will be a link in the navigation block ONLY if you enable it within the blocks setting?

        Howard Miller added a comment -

        Suits me. I appreciate that most users probably won't care one way or another

        Sam Hemelryk added a comment -

        I've just attached a patch that adds a block config setting that allows categories to be displayed as links but by default doesn't.
        This also means that categories are permanently links on the navbar.

        If you're both happy with this I'll get someone to review it and get it in otherwise we'll continue discussing it.

        Cheers
        Sam

        Sam Hemelryk added a comment -

        Hi guys,

        Petr or Martin could one of you please review the attached patch.

        Cheers
        Sam

        Petr Škoda added a comment -

        +1 looks ok, but I did not test it, please double test before commit

        Sam Hemelryk added a comment -

        Alright, thanks for the review Petr, I triple checked it and turned up one area I forgot to update with the new config option (the ajax loading of categories) which I have now fixed.
        I've commit the patch so in 2.0.1 that option will be there.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: