Moodle
  1. Moodle
  2. MDL-24118

Admins can't see Course file repository

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Files API
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      26093

      Description

      In Moodle 2.0 Preview 4+ (Build: 20100907) Admins are not able to see Course file repository. To reproduce:

      • enable course file repository in Admin
      • access either site home page or a course home page
      • no "Course file" is present in settings block
      • accessing the file picker, no course file is present (probably here it should not)
      • in the Site admin, course files is not listed

        Activity

        Dongsheng Cai added a comment -

        It is not a bug:
        Site administration -> Development -> Experimental -> Experimental settings
        tick 'Legacy course files in new courses'

        Then go to course setting:
        select Legacy course files == true

        Then you will see the course files in your course view.

        I understand that's difficult to find. But in moodle 2, we don't really want users still use course files.

        Andrea Bicciolo added a comment -

        Hi Dongsheng, wow, thanks for your clarification! Sorry for reopening, just two considerations:

        1) in my opinion, if we really do not want legacy files, obfuscation will not prevent it.
        2) if legacy files is an experimental setting, then legacy file repo it should not appear in the list of available repositories in the admin's manage repository page, unless the Experimental setting "legacyfilesinnewcourses" is selectd.

        Dongsheng Cai added a comment -

        Hi, Andrea

        Please move along to MDL-23308 for further discussion about 'course files'

        Helen Foster added a comment -

        Hi Andrea,

        Thanks a lot for your report. I was about to create a "Can't see course files" issue too, but luckily I searched and found this issue containing Dongsheng's explanation! I have added it to Moodle Docs - http://docs.moodle.org/en/Legacy_course_files - for others who will no doubt be asking the same question.

        As Dongsheng mentions, the discussion about course files in Moodle 2.0 is ongoing, and there are still things which need to be figured out. I was also wondering about the legacy course files repository plugin, thinking it should perhaps be enabled if there are courses which have been upgraded from 1.9.

        Anyway, let us follow Dongsheng's suggestion and use MDL-23308 for further discussion, and I will mark this issue as resolved since admins can see the course files if all the steps are followed!

        PS Thanks Dongsheng for your explanation and suggestion

        Kameron Pence added a comment -

        Where are these settings referred to here? I went to the Legacy course files doc mentioned by Helen above. I am using RC1 and there is no legacy setting under experimental settings, there is no legacy option in course settings. The only place I see legacy course repository is under the manage repository option. I have it enabled and visible, but it is not showing up in file picker.

        Suzanne added a comment -

        I am having the same problem as Kameron. When I go to Site Administration > Development > Experimental > Experimental Settings there is no option for "Legacy course files in new course".

        Helen Foster added a comment -

        Apologies for the confusion. It seems that the legacyfilesinnewcourses checkbox has been moved from experimental settings to the Manage repositories common settings. I've just updated http://docs.moodle.org/en/Legacy_course_files Please shout if you follow the 3 steps and still don't see a legacy course files link in the course administration block!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: