Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24261

Editing true/false question, "Correct answer" isn't gathered ok, and always shows "false"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Questions
    • Labels:
      None
    • Database:
      Any
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      To reproduce:

      • Create one true/false question
      • Set "correct answer" to true and then the true and false feedbacks.
      • Save the question
      • Everything is ok (question_answers show the correct "fraction"
      • Edit the question, the "correct answer" defaults to false (easy to forget).

      Expected result:

      • Correct answer should be gathered correctly

      Current result:

      • If you save that edited question, the answers "fraction" gets interchanged, so the initially correct answer becomes the incorrect and vice-versa.

      Ciao

        Attachments

          Activity

            People

            Assignee:
            ppichet Pierre Pichet
            Reporter:
            stronk7 Eloy Lafuente (stronk7)
            Tester:
            Eloy Lafuente (stronk7)
            Participants:
            Component watchers:
            Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10