Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24282

Forum: Subscriptions page right and left arrows are not displaying properly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Forum
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      If you pull up a forum subscriptions page and turn editing on, the forum renderer does not seem to be displaying rarrow and larrow correctly.

      In /lib/outputcomponents.php the attribute function returns:

      return ' ' . $name . '="' . s($value) . '"';

      So the ampersand is being quoted. Removing s() - in other words:

      return ' ' . $name . '="' . $value . '"';

      shows the correct characters; however, Petr commented:

      // no sloppy trimming here!

      when he added the code:
      http://cvs.moodle.org/moodle/lib/outputcomponents.php?view=diff&r1=1.72&r2=1.73

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              skodak Petr Skoda
              Reporter:
              aborrow Anthony Borrow
              Tester:
              Nobody
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                24/Nov/10