Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24445

Moodle 2.0 RC1 fails Fresh install (Sept 29 CVS)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      Ubuntu server stack
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Fresh CVS Sept 29. Doing fresh install, receive error:

      Fatal error: Call to a member function set_context() on a non-object in /var/www/moodle/moodle2/lib/weblib.php on line 2522

      When I comment out this line, the install proceeds fully (although the step step of system takes several minutes even on a fast machine, something I will report in a different bug issue).

        Gliffy Diagrams

          Attachments

            Activity

            ganderson Gary Anderson added a comment -

            On further checking, this error was resolved when I ran:

            apt-get install php5-intl

            and reappeared when I ran

            apt-get remove php5-intl

            Since the intl extension is recommended and not required (according to the installation recommendation screen) I would suggest either changing the requirement or changing the call so as to not produce a fatal error.

            --Gary

            skodak Petr Skoda added a comment -

            Should be fixed now, the regression was caused by my recent fix for other PAGE context problem, sorry.
            Thanks for the report.

            Petr Skoda


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10