Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24448

Lesson questions without answers causing problems in Lesson Demo

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.10
    • Component/s: Lesson
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Either the code needs to change, or we need to add some answers to a few questions in the Lesson Demo. I only looked at a MC questions in Lesson-Basic parts in QA.

      Basically Lesson gets into an endless loop with a continue button for a student or a teacher in preview mode when it is on a MC question with no answer. And of course this is only possible when a existing lesson like Lesson-Basic parts exists. I have noticed for the first time a *Required on two answers in a MC question in a lesson.

      In 1.9.9 and earlier, a MC question without an answer1, would display a continue button. When pressed this action would take the user to the next page in the edit order. I do not remember if it scores the question in custom or non-custom scoring mode in 1.9.9 . If the teacher skipped answer1 and recorded something in answer2, Lesson would ignore it and only put up the continue button.

      In the Lesson-Basic parts demo, there are several multiple choice questions that intentionally do not have an answer. Thus the lesson does not work.

      In QA I only put in an answer in the first "required" slot. It did not like it and kicked it back telling me I had missed a required field.

      Willing to be part of a solution to edit the Lesson to solve this issue.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jul/12