Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24467

Feedback 1.9 => 2.0 upgrade broken (wrong DB call)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Feedback
    • Labels:
      None

      Description

      From forums @ http://moodle.org/mod/forum/discuss.php?d=159206

      On upgrade:

      Debug info: Argument 2 passed to moodle_database::get_records() must be an array, string given, called in /home/webadmin/html/mod/feedback/db/upgrade.php on line 146 and defined
      Stack trace:
      line 309 of /lib/setuplib.php: coding_exception thrown
      line 1022 of /lib/dml/moodle_database.php: call to default_error_handler()
      line 146 of /mod/feedback/db/upgrade.php: call to moodle_database->get_records()
      line 490 of /lib/upgradelib.php: call to xmldb_feedback_upgrade()
      line 265 of /lib/upgradelib.php: call to upgrade_plugins_modules()
      line 1348 of /lib/upgradelib.php: call to upgrade_plugins()
      line 298 of /admin/index.php: call to upgrade_noncore()

      There is one incorrect use of $DB->get_records()

      Ciao

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              grabs Andreas Grabs
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Tester:
              Nobody
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                24/Nov/10