Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24646

Student can't export chat sessions to their portfolio

    Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Chat, Portfolio
    • Labels:
      None
    • Environment:
      Moodle 2.0RC1
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      This ticket relates to MDLQA-487.

      This test requires the following:
      Portfolios and the file download and Google Docs portfolio plugins to be enabled for the site
      A course containing a chat activity with at least one saved chat session which everyone can view
      A Google Docs account for use in testing
      1. Login as a student, and access the chat activity.
      2. View a past chat session and click the save link.
      3. Try exporting the data, selecting file download as the portfolio.
      4. Save the file locally then open it and check that all data has been exported correctly.
      5. Try exporting the data again and select Google Docs as the portfolio.
      6. Login to your Google Docs account.
      7. Check that the file is exported correctly to Google Docs.

      Result

      Steps 1-2: pass
      Steps 3-7: fail.

      After students exit the chat session, they have an option to view the previous session, however, there is no option to export to portfolio.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              chadsta Chad Outten created issue -
              andyjdavis Andrew Davis made changes -
              Field Original Value New Value
              Fix Version/s 2.0 [ 10122 ]
              Priority Minor [ 4 ] Blocker [ 1 ]
              andyjdavis Andrew Davis made changes -
              Link This issue will help resolve MDLQA-487 [ MDLQA-487 ]
              dongsheng Dongsheng Cai added a comment -

              fixed

              dongsheng Dongsheng Cai made changes -
              Status Open [ 1 ] Resolved [ 5 ]
              Resolution Fixed [ 1 ]
              tsala Helen Foster added a comment -

              Reopening, as there still doesn't seem to be a link for exporting a chat session. (Confirmed by James in MDLQA-487 plus I've just tried on http://qa.moodle.net/.)

              I've added Penny as a watcher in case you can help.

              tsala Helen Foster made changes -
              Resolution Fixed [ 1 ]
              Status Resolved [ 5 ] Reopened [ 4 ]
              dongsheng Dongsheng Cai added a comment -

              Hi, Helen

              It is not a bug, student must be assigned 'Export chat session' capability to export chat log.

              dongsheng Dongsheng Cai made changes -
              Attachment Selection_019.jpeg [ 22113 ]
              dongsheng Dongsheng Cai made changes -
              Status Reopened [ 4 ] Resolved [ 5 ]
              Resolution Not a bug [ 7 ]
              dongsheng Dongsheng Cai added a comment -

              Please see attached screenshot.

              tsala Helen Foster added a comment -

              Thanks for explaining things Dongsheng. I've updated the QA test together with the master copy of the test to include the role of student has permission to export chat sessions condition.

              mjollnir Penny Leach added a comment -

              by the way, there's a good reason for this not being on by default, which is that the chat session contains "work" made by other students.

              tsala Helen Foster added a comment -

              Thanks Penny, I took a look at similar forum permissions and came to the same conclusion about the default setting.

              dougiamas Martin Dougiamas made changes -
              Status Resolved [ 5 ] Closed [ 6 ]
              QA Assignee nobody
              dougiamas Martin Dougiamas made changes -
              Workflow jira [ 39489 ] MDL Workflow [ 65833 ]
              dougiamas Martin Dougiamas made changes -
              Workflow MDL Workflow [ 65833 ] MDL Full Workflow [ 95180 ]

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10