Moodle
  1. Moodle
  2. MDL-24734

SCORM Package: Scoring overview reporting grade with incorrect percentage

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.3
    • Component/s: SCORM
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      6405

      Description

      Using SCORM 1.2 test package from:

      http://www.adlnet.gov/Technologies/scorm/SCORMSDocuments/Previous%20Versions/SCORM%201.2/SCORMContentPackageExamples.zip

      Create activity and set 'maximum grade' to 5 (the maximum total set by the package - it has five questions and sends a cmi.score.raw of 1-5).

      Grades reported on the SCORM package 'Info' tab are in percent but show the mark assigned and do not take into consideration the 'maximum grade' setting (so if I get 5 out of 5 it shows 5% not 100%).

      Scores are correctly recorded in the gradebook and reflect the maximum grade setting (so if I get 5 out of a maximum of 5 the gradebook reports a total of 100%).

      According to http://www.scormcourse.com/scorm12_course/resources/coreScoreRaw.html cmi.score.raw could be either a score or a percentage.

        Activity

        Dan Marsden added a comment -

        Hi Jason,

        thanks for the report - can you please add a screenshot of the issue? - there are a range of ways that SCORM displays grades and I want to make sure I can see exactly where the issue is.

        thanks,

        Dan

        Dan Marsden added a comment - - edited

        also - which max grade are you setting? - the one on the scorm settings page or the cmi.core.score.max? - also do you have "display attempt status" set to "true" ?

        could you include a list of all the SCORM settings you have made and which test package you are using which reproduces the issue?

        thanks,

        Jason Platts added a comment -

        I am using the maximum grade option in the module settings, the sco does not seem to use api calls to set the max score.

        _scorm DB row for module is as follows:

        2;2;"scorm example 2";"local";"multimultisco";"<p>multi-multi lesson</p>";1;"SCORM_1.2";5;1;0;0;0;0;0;1;0;3;"e02a9d3974eb70a85ccad2c9f5b55f93961acf04";"''";8;59;0;0;2;0;0;0;"''";100;500;0;0;1287475837

        I will attach screen-grab and sco.

        Jason Platts added a comment -

        Screenshot & sco

        Dan Marsden added a comment -

        finally got round to sorting a fix - Pull request has been submitted - thanks for the report!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: