Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24743

display error in the theme magazine

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.3
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      attached is how theme magazine appears on my local installation

        Gliffy Diagrams

          Attachments

          1. err.gif
            err.gif
            75 kB
          2. error_appears.png
            error_appears.png
            68 kB
          3. magazine-nav.jpg
            magazine-nav.jpg
            34 kB
          4. nominsize.png
            nominsize.png
            68 kB
          5. pref.png
            pref.png
            76 kB
          6. Schermata-2010-10-28-a-07.3.gif
            Schermata-2010-10-28-a-07.3.gif
            134 kB

            Activity

            epsd John Stabinger added a comment -

            Daniele,

            Is that the front page? Could you confirm the appearance on another site. For example, does http://qa.moodle.net/?theme=magazine

            also appear that way? Thanks!

            daniss Daniele Cordella added a comment -

            Ciao John
            yes, it is the home page
            and
            yes the strange behaviour is the one you get even in http://qa.moodle.net/?theme=magazine once logged in.
            I attach what I see in http://qa.moodle.net/?theme=magazine, too.
            Ciao and thanks for your intervention.

            epsd John Stabinger added a comment -

            I can't seem to replicate this (even http://qa.moodle.net/?theme=magazine looks fine on all of the systems I tested it on). Can you give me more info about the system and browser you are using?

            daniss Daniele Cordella added a comment -

            Ciao John
            I am using firefox 3.6.12 on mac with snow leopard.
            To be honest I have to say that I just found that what I see in http://qa.moodle.net/?theme=magazine from my mac in the office is different from what I see in the same site from here, at home.
            Yesterday I thought it was a problem of the theme, now I strongly believe it is a problem of my computer in the office.
            Tomorrow I will start further investigation.
            I'll update this issue with news.
            Thanks.

            daniss Daniele Cordella added a comment -

            ok, today I have to stop submitting answers before the second check!
            Sorry
            I do confirm the problem even from my computer at home.
            The problem is not present if not logged in and is present once logged.
            I tried to login as manager as far as student or teacher and the problem is always the same described in the attachment.

            epsd John Stabinger added a comment -

            I tested using the same system specs (osx 10.6 and ff 3.6.12) as you and cannot replicate. I'll have to see if I can get some other people to test and report back.

            epsd John Stabinger added a comment -

            Cannot replicate issue on any system tested.

            lazydaisy Mary Evans added a comment -

            This problem has not gone away. I must admit I thought it was fixed, but apparently not. I was trying to test some CSS for a Moodler who had asked a question on the Theme's forum. Loading Magazine this evening, I got the same problem as Daniele. A screenshot is added to clarify same problem.

            Thanks
            Mary

            OS: WindowsXP (SP3 and latest updates) FireFox 3.6.13 (recently updated) JavaScript enabled. WAMP Server - PHP (5.3) MySQL (5.1.36) Apache (2.2.11)

            lazydaisy Mary Evans added a comment -

            Magazine Theme Navbar/Breadcrumb problem

            daniss Daniele Cordella added a comment -

            I just found that deleting the row
            line-height: 40px; (about line 283)
            in the selector div#jcontrols_button span.arrow.sep
            in the file
            /magazine/style/core.css
            the error disappear.

            Please, John, test and commit this change.
            Thanks in advance.

            P.S.
            Mary, does this change fix your problem too?

            daniss Daniele Cordella added a comment -

            reopening because one possible solution has been found and some more comments may help to close this issue definitely

            epsd John Stabinger added a comment -

            Mary found that the issue was something wrong with her browser. I still cannot replicate this issue anywhere.

            daniss Daniele Cordella added a comment - - edited

            I believe I found the reason of this odious bug.
            If, in firefox, it is set a minimum font size, as the I usually set, the bug is simple to view.
            If the minimum font size is set to none, the bug disappear.
            I do attach 3 screen shot I made to explain where I changed the minimum font size in FF to let you get evidence of the bug too.
            In spite of this, I still believe that my suggestion of 21/Jan/11 11:29 PM here above is useful.

            Hope you can now experience the problem.
            Let me know, please.
            Ciao.

            tsala Helen Foster added a comment -

            Thanks everyone for your comments and thanks to John for fixing this issue. The fix is available in the latest 2.0.2+.


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11