Moodle
  1. Moodle
  2. MDL-24746

Activity completion: obtaining grade in Assignment module does not update grade completion

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Gradebook
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      32089

      Description

      Undertaking MDLQA-527, activities do not show as completed on the activity completion report.

        Issue Links

          Activity

          Sam Marshall added a comment -

          Not able to reproduce this - when I do it, it shows as completed.

          Sam Marshall added a comment -

          OK - Anthony has shown me this.

          To reproduce the bug, you have to give the student a grade using the Assignment module controls to give the grade. When you do that, it is not marked on the report.

          If you give them a grade using the Grade page directly, this is marked on the report.

          Sam Marshall added a comment -

          Also when I used grade report and turned off override to clear the grade, this should have cleared the completion, but it did not.

          Sam Marshall added a comment -

          I think this is fixed now, at least it worked when I tested it. I don't actually understand why assignment wasn't working, but when I fixed the 'turning off override doesn't clear it' part, after that assignment seemed to work anyway .

          Reopen if it's still broken...

          Sam Marshall added a comment -

          Note (b/c not sure how this should be recorded): I also marked as duplicate of the issue for MDLQA-514. Have reset both tests.

          Mark Berthelemy added a comment -

          I'm running Moodle 2.0 RC1 (Build: 20101102)

          The process I went through is:
          1) Create graded assignment
          2) Grade student work
          3) Set up completion status to show when assignment is graded

          I cannot get the completion status to show as completed, even after logging out the student and logging back in again.

          Regrading the student's work then brings up the tick again.

          So, it looks like you cannot set up the completion status settings after you've already graded a student.

          Sam Marshall added a comment -

          This is probably the case with most activity types.

          I guess it should be fixed - not quite sure how at this point. I think there is some logic that is used if you change the completion settings after some users have already completed the activity, but maybe that logic does not run if you change the completion settings when nobody has completed it yet.

          Sam Marshall added a comment -

          I think I have fixed this now. I did the following:

          • In the module editing form, if there is no existing completion data, it automatically 'unlocks' completion settings (meaning that completion data is recalculated when you save changes).

          Previously, you got an option to unlock completion data by clicking a button, but this applied only when there was existing completion data that would potentially be lost. When there was no completion data, it remained in the 'locked' state, assuming that there was no need to update it.

          • In the module edit handling code, I noticed that completion data was updated before saving the changes to the course-module object, which didn't sound like a good idea, so I moved the code slightly later.

          I retested using the scenario given and it now appears to work. As previously mentioned, if you are already logged in as the user (who has now completed something), the change will not show until you log out/log in again. It shows immediately to admin, if you look at the activity completion report.

          Mark: Thanks for reporting this issue!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: