Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-24984

Text spacing issue on front page categories

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Language, Themes
    • Labels:
      None
    • Environment:
      LAMP, all up to date, Moodle 2.0 RC1 (Build: 20101101)
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      When I add course categories to the front page of a fresh Moodle 2 install, the number of courses in the category is *not* separated from the name of the category by a space, which looks odd. Please see attached image.

      Not sure if this is a language issue or a theme issue, so added to both.

        Gliffy Diagrams

        1. spacing_issue_patch.txt
          0.8 kB
          Paul Vaughan
        1. spacing_example.png
          4 kB

          Activity

          koen Koen Roggemans added a comment -

          Hi, we need a little bit more information to be able to assign this to the right person. Can you take a look at the following list please?

          Does it occur with the standard theme? -> moodle.com issue
          Does it only occur with your theme? -> theme makers issue
          Does it occur in all languages -> moodle.com issue
          Does it occur only in a certain language -> language pack maintainer issue

          koen Koen Roggemans added a comment -

          It seems to be everywhere.
          Tested in English, Dutch, German
          Tested with Standard theme and Anomaly.

          So I think it is on coding level. Reassigning

          vaughany Paul Vaughan added a comment -

          Hi Koen.

          I have seen this issue with every current stock Moodle 2 theme (as of the build on the day this bug was filed). Sorry I forgot to mention this in my original post.

          Does it occur with the standard theme? -> yes
          Does it only occur with your theme? -> no (no custom themes developed yet)
          Have not checked if the issue is still present with different languages.

          vaughany Paul Vaughan added a comment -

          The function print_category_info() in course/lib.php appears to be responsible, lines just after 1909 especially.

          The table cell is styled with class="category number", could this be modified or added to in some way to move the cells further apart?

          vaughany Paul Vaughan added a comment -

          There may be a better way of doing it but this works for us.

          poltawski Dan Poltawski added a comment -

          Thanks for the report and patch. I've created PULL-91 for this change to be applied upstream


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                21/Feb/11