Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      Moodle 2.0 RC1 (Build: 20101102)
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      2770

      Description

      Setup:
      Settings:

      • Retakes allowed: no
      • Allow Student Review: No
      • Provide option to try a question again: No
      • Max # of attempts: 1

      Question setup:

      • 1 numerical Question page as follows
        • Correct ans: with jump to next page
        • Incorrect ans: with jump to same page
        • Incorrect ans: with jump to same page
        • Incorrect ans: with jump to same page
      • 1 Essay Question page
      • Student account:
        1. If I answer the numerical question wrong it gives me the feedback with a continue button
        2. I click continue, the next question is displayed.
      • Teacher account(another browser):
        1. Question is shown as answered incorrectly.
      • Student account:
        1. Click back button, asks me if I want to resubmit, I say yes, then quickly click back again before it loads. (some times I have to click back until I get to the course screen then click forward)
        2. Displays message: "You have seen more than one page of this lesson already.\nDo you want to start at the last page you saw?"
        3. Select No, sends back to start of first question,
        4. Now enter in the new value and click continue blah blah...continue on do what ever
      • Teacher account:
        1. Look at the attempt -> the question value is changed to the new value.

        Activity

        Hide
        Michael de Raadt added a comment -

        Thanks for reporting this issue.

        We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

        If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

        Michael d.

        TW9vZGxlDQo=

        Show
        Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
        Hide
        Michael de Raadt added a comment -

        I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

        This is being done as part of a bulk annual clean-up of issues.

        If you still believe this is an issue in supported versions, please create a new issue.

        Show
        Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: