Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25067

mform editor element can not be disabled with mform->disabledIf method

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: FRONTEND
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      As explained in
      http://moodle.org/mod/forum/discuss.php?d=161540
      it seems there is no way to disable an editor field.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mudrd8mz David Mudrák added a comment -

              This issue was assigned to me, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue. For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

              skodak Petr Skoda added a comment -

              Fixed long time ago, thanks for the report.

              daniss Daniele Cordella added a comment - - edited

              Thanks Petr for the clarification.
              Can you address me to a working example, please?

              skodak Petr Skoda added a comment -

              What example? Go to the list of editors and click eye icon.

              skodak Petr Skoda added a comment -

              Aah, I was reading it wrong, reopening.

              marina Marina Glancy added a comment - - edited

              Hi, this issue has a duplicate of MDL-29421 with more details and attached patch, therefore I'm closing this one to defer the work to MDL-29421, please follow MDL-29421 instead


                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: