Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Forum, Language
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      The original translation for the "cannotsubscribe" identifier in the forum module is "Sorry, but you must be a group member to subscribe.". However this is not a proper text for this identifier (based on its usage).

      for example, in forum/subscribe.php, the code around line 134 is:

      if (!has_capability('mod/forum:viewdiscussion', $context)) {
          print_error('cannotsubscribe', 'forum', $_SERVER["HTTP_REFERER"]);
      }

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            mudrd8mz David Mudrák added a comment -

            I fixed the two other usages of the string so that now it is used for the group membership check only. Thanks for spotting this Shamim!

            Show
            mudrd8mz David Mudrák added a comment - I fixed the two other usages of the string so that now it is used for the group membership check only. Thanks for spotting this Shamim!

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Dec/10