Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25114

Warning in message API

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Messages
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I'm using message API in hub, when I call message_send($eventdata); it works but there is a warning:

      PHP Notice: Error finding message processor <ul style="text-align: left"><li>line 149 of /lib/messagelib.php: call to debugging()</li><li>line 116 of /local/hub/sendmessage.php: call to message_send()</li></ul> in /Users/jerome/Documents/Projects/Moodle_HEAD_secure_hub/moodle/lib/weblib.php on line 2881

      It is caused because $processor value is

      Array
      (
      [0] =>
      )

      in the code:

      if ($processor!='none') {
      $processorlist = explode(',', $processor);

      //var_dump($processor)

      foreach ($processorlist as $procname) {
      $processorfile = $CFG->dirroot. '/message/output/'.$procname.'/message_output_'.$procname.'.php';

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                andyjdavis Andrew Davis
                Reporter:
                jerome Jérôme Mouneyrac
                Tester:
                Nobody
                Participants:
                Component watchers:
                Jake Dallimore, Jun Pataleta
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  24/Nov/10